HDU 1520 Anniversary party【树形DP入门】

A n n i v e r s a r y   p a r t y Anniversary\ party Anniversary party

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20850Accepted Submission(s): 7550

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

Source
Ural State University Internal Contest October’2000 Students Session

  \  
树形DP的入门题,题意是:给出一棵树,每个节点都有一个权值,相连的两个点不能同时选,问怎么选人能使权值和最大。

先gao出状态转移方程,如果正向递推的话没办法找到一个选择方案,所以需要反向递推,dp[i][0]表示不选i点的最大值,dp[i][1]表示选i点的最大值,状态转移方程是:

D P [ n o w ] [ 1 ] = ∑ s o n = 1 n u m _ o f _ s o n s D P [ s o n ] [ 0 ]   +   v a l [ n o w ] DP[now][1] = \sum ^{num\_of\_sons} _{son=1}DP[son][0]\ +\ val[now] DP[now][1]=son=1num_of_sonsDP[son][0] + val[now]

D P [ n o w ] [ 0 ] = ∑ s o n = 1 n u m _ o f _ s o n s m a x ( D P [ s o n ] [ 0 ] , D P [ s o n ] [ 1 ] ) DP[now][0] = \sum ^{num\_of\_sons}_{son=1} max(DP[son][0],DP[son][1]) DP[now][0]=son=1num_of_sonsmax(DP[son][0],DP[son][1])

假设起始点为st,从起始点开始进行dfs,回溯的时候dp就好了,最后答案就是max(dp[st][0],dp[st][1])

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 6e3+7;
const int maxm = 1e5+7;
struct EDGE{
    int to,next;
};
EDGE edge[maxm];
int n,edge_num;
int head[maxn],hap_val[maxn],indegree[maxn],dp[maxn][2];
void init(){
    edge_num = 0;
    memset(dp,0,sizeof(dp));
    memset(indegree,0,sizeof(indegree));
    memset(head,255,sizeof(head));
}
void add_edge(int u,int v){
    edge[edge_num].to = v;
    edge[edge_num].next = head[u];
    head[u] = edge_num++;
    indegree[v]++;
}
void input(){
    init();
    for(int i=1;i<=n;i++) scanf("%d",&hap_val[i]);
    int pa,pb;
    while(scanf("%d %d",&pa,&pb)!=EOF && pa+pb) add_edge(pb,pa);
}
void dfs(int now){
    int suma=hap_val[now],sumb=0;
    for(int i=head[now];i!=-1;i=edge[i].next){
        int v = edge[i].to;
        dfs(v);
        suma+=dp[v][0];
        sumb+=max(dp[v][1],dp[v][0]);
    }
    dp[now][0] = sumb; dp[now][1] = suma;
}
int solve(){
    int st;
    for(int i=1;i<=n;i++) if(indegree[i]==0){
        st = i;
        break;
    }
    dfs(st);
    return max(dp[st][1],dp[st][0]);
}
int main(){
    while(scanf("%d",&n)!=EOF){
        input();
        printf("%d\n",solve());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值