POJ 1026 Cipher(置换)

传送门:http://poj.org/problem?id=1026
Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.
Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
Sample Output

BolHeol b
C RCE

题意

  读了好久才明白题意,以样例来解释一下题意:

  1. 首先输入一个n(当n==0时,停止输入)
  2. n个密钥ai(0<ai<=n),初状态 4 5 3 7 2 8 1 6 10 9,末状态 1 2 3 4 5 6 7 8 9 10,置换群:(4 1 7)(5 2)(3)(8 6)(10 9)
  3. 给定一个k(当k==0时,停止输入),表示后面语句每个字符置换的次数
  4. 输入语句cmd,如果cmd的长度小于n,用空格补位
  5. 让你输出经过k次转换后的加密语句,每组n之间有一个空行做间隔
    Hello Bob 为例,不足10位,补空格,1表示H,2表示e,3表示l,……,9表示b,10表示空格,(4 5 3 7 2 8 1 6 10 9)经过1次转换后(7 5 3 1 2 8 4 6 10 9),对应位数输出字符即可

思路

  先找出所有置换循环,然后对于每一位来计算(k%循环长度)后对应于哪个位置,O(n)复杂度。注意读写方面的东西。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<stack>
#include<queue>
#include<ctype.h>
#include<vector>
#include<algorithm>
#include<sstream>
#define PI acos(-1.0)
using namespace std;
typedef long long ll;
typedef unsigned long long llu;
const int inf = 0x3f3f3f3f;
const ll lnf = 0x3f3f3f3f3f3f3f3f;
const int maxn = 210;
char cp[maxn],ans[maxn];	//初始语句,加密语句
int a[maxn],c[maxn];	//密钥,循环节的周期
int main(void)
{
    int n,k;
    while(scanf("%d",&n),n){
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++){	//求解每个循环节的周期
            int j = i;
            while(a[j]!=i){
                c[i]++;
                j = a[j];
            }
            c[i]++;
        }
        /*for(int i=1;i<=n;i++)
            cout<<c[i]<<' ';
        cout<<'\n';*/
        while(scanf("%d",&k),k){
            getchar();
            gets(cp+1);	
            int len = strlen(cp+1);
            while(len<n)    cp[++len] = ' ';	//补空格
            cp[n+1] = 0;	
            for(int i=1;i<=n;i++){
                int p = k % c[i];
                int j = i;
                while(p--)  j = a[j];
                //cout<<j<<' '<<i<<' '<<cp[i]<<endl;
                ans[j] = cp[i];	//加密
            }
            ans[n+1] = 0;	//**
            puts(ans+1);	//**
        }
        puts("");	//**
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值