HDU 5573 Binary Tree

题目链接:https://vjudge.net/problem/HDU-5573

The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.
Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.
And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.
Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.
Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.
He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.
Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.
Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input
First line contains an integer T, which indicates the number of test cases.
Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.
⋅ 1≤T≤100.
⋅ 1≤N≤109.
⋅ N≤2K≤260.

Output
For every test case, you should output “Case #x:” first, where x indicates the case number and counts from 1.
Then K lines follows, each line is formated as ‘a b’, where a is node label of the node the frog visited, and b is either ‘+’ or ‘-’ which means he increases / decreases his number by a.
It’s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input
2
5 3
10 4

Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +

题意

  一个完全二叉树,根节点的数值为1,如果父节点的值为 x ,那么子节点的值分别为 2x 和 2x-1,若到达没有节点,那么对应的可以加上或减去该节点的数值,给出最终数值和走的步数,输出一种方案。

思路

  树的 2x 这一方向的值是 2、4、8、16、…,对于这个方向上的数值进行 + 或 - 的操作,无论什么数据,如果合法,一定可以从这个方向完成,如果最后结果是偶数,最后 +1 即可。

  于是问题就转换成了从 1、2、4、8、16…走下去,对应每个数取正或取负,由于全是 2 的幂,因此可将问题转换为二进制,并且用 0 表示加法,用 1 表示减法。

  经过 1<<k 后,再减去 n 得到 1<<k-n,然后将这个数的二进制从右向左第二位开始判断,如果是 1,表示这位的数字为负,如果是 0,表示这位数字为正

#include<iostream>
#include<string>
#include<algorithm>
#include<fstream>
using namespace std;
typedef long long ll;
int main(void)
{
    int t;
    ll n,k;
    cin>>t;
    for(int cas=1;cas<=t;cas++){
        scanf("%lld%lld",&n,&k);
        ll tmp = (ll)1>>k;
        tmp -= n;
        cout<<"Case #"<<cas<<":\n";
        for(int i=1;i<k;i++){
            if(tmp&(1<<i)){
                printf("%lld -\n",(ll)1<<(i-1));
            }
            else{
                printf("%lld +\n",(ll)1<<(i-1));
            }
        }
        tmp = (ll)1<<(k-1);
        if(n%2==0)   tmp++;
        printf("%lld +\n",tmp);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值