Cutting Sticks(线性区间DP)

  You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of workrequires that they only make one cut at a time.It is easy to notice that different selections in the order of cutting can led to different prices. Forexample, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.
  Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price.
  Your boss trusts your computer abilities to nd out the minimum cost for cutting a given stick.
Input
  The input will consist of several input cases. The rst line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n(n<50) of cuts to be made.
  The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
  An input case with l = 0 will represent the end of the input.
Output
  You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.
SampleInput
100
3
25 50 75
10
4
4 5 7 8
0
SampleOutput
The minimum cutting is 200.
题目大意:有一个长为L的棍子,还有n个切割点的位置(按从小到大排列)。你的任务是在这些切割点的位置处把棍子切成n+1部分,使得总切割的费用最少。每次切割的费用等于被切割的木棍长度。
要求:最小花费
  我们定义dp(i,j),表示切割第i、j切割点之后得到的木棍;
  设这根木棍上有第K个切割点,显然 i < k < j;
  显然木棍被分成了两段,切割的花费a[j]-a[i];
  那么切割成dp(i,j)段的花费:dp[i][j] = min(dp[i][k]+dp[k][j]+a[j]-a[i]);
  把左又端点分别看成第0个和第n+1个切割点,a[0] =0,a[n+1] =L;
初始化:
最初的状态是不能再切割的子木棍。就是木棍(i,j)之间不存在切割点,
具体就是dp[0][1] 、dp[1][2]、dp[2][3]、d[3][4] …d[n][n+1],因为它们是不能再切割的,所以它们的初始值都是0.

memset(dp,inf,sizeof(dp));
for(int i=1;i<=n-1;i++)
	dp[i-1][i] = 0;

状态转移方程:

for(int i=n;i>=0;i--){
	for(int j=i+1;j<=n;j++){
		for(int k=i;k<=j;k++){
			dp[i][j] = min(dp[i][j],dp[i][k]+dp[k][j]+a[j]-a[i]);
		}
	}
}

AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
const int inf = 0x3f3f3f3f;
using namespace std;
int a[100];
int dp[100][100];
int main(void)
{
    int n,l;
    while(scanf("%d",&l),l){
        scanf("%d",&n);
        a[0] = 0;
        memset(dp,inf,sizeof(dp));
        for(int i=1;i<=n;i++){
            scanf("%d",a+i);
            dp[i-1][i] = 0;
        }
        a[n+1] = l;
        dp[n][n+1] = 0;
        for(int i=n;i>=0;i--){
            for(int j=i+1;j<=n+1;j++){
                for(int k=i;k<=j;k++){
                    dp[i][j] = min(dp[i][j],dp[i][k]+dp[k][j]+a[j]-a[i]);
                }
            }
        }
        printf("The minimum cutting is %d.\n", dp[0][n + 1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

逃夭丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值