HDU4821(hash+map)

(边界问题已更新)
题目:Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
(i) It is of length M*L;
(ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string “aa” has 3 different substrings “aa”, “a” and “a”.

Your task is to calculate the number of different “recoverable” substrings of S.InputThe input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.OutputFor each test case, output the answer in a single line.
Sample Input
3 3
abcabcbcaabc
Sample Output
2
大致题意:给你一个字符串和两个整数 m,l。让你找字符串中有多少个满足条件的字串。条件1:字串长度ml(意思就是由m个长度为l的连续的小字串组成),条件2:m个小子串各不相同。
思路:可以很简单的想到要找到m个连续的长度为l的小子串,但是按正常的字符串解法,无法判断字串里的m个小子串是否重复。这时候就要用到hash了。做法是把长度为l的小子串映射成一个数值,再用一个map记录数值是否重复即可。hash做法emmm…举个栗子吧 题目中的字母范围‘A’-‘Z’,可以理解为一个字母为1个26进制的一位数(几进制为所谓,反正比26大就行了)。'AA’可以映射成0
26+0,‘BB’映射为’1*26+1’。hash后保证了不同的字符串值不相等。扫描的时候不是一位位扫下去的,这样铁超。扫描过程中,每次推进l位,即map去掉前l位的值再加入m8l串后面l位的值,这样扫描l个循环就行了。即第一次起点为1,扫到结束再从起点为2开始,外圈循环<l。

#include<bits/stdc++.h>
using namespace std;
typedef unsigned long long int ull;
typedef long long int ll;
const int maxn=100010;
const int sead=31;
ull h[maxn],base[maxn];
map<ull ,int >mp;
ull gethash(int l,int r)//获取字符串hash值
{
    return h[r]-h[l-1]*base[r-l+1];
}
int main()
{
    base[0]=1;
    for(int i=1;i<maxn;i++)base[i]=base[i-1]*sead;//每一位的基础hash
    char s[maxn];
    int m,l;
    while(scanf("%d%d",&m,&l)!=EOF)
    {
        scanf("%s",s+1);
        int len=strlen(s+1);
        h[0]=0;
        int i;
        for(i=1;i<=len;i++)//开始hash
        {
            h[i]=h[i-1]*sead+s[i]-'a'+1;
        }
        int ans=0;
        for(i=1;i<=l && i+m*l-1<=len;i++)//扫描l次
        {
            mp.clear();
            for(int j=i;j<i+m*l;j+=l)
            {
                ull x=gethash(j,j+l-1);
                mp[x]++;
            }
            if(mp.size()==m)ans++;
            for(int j=i+m*l;j+l-1<=len;j+=l)//添头去尾的扫描
            {
                ull x=gethash(j,j+l-1);
                mp[x]++;
                ull y=gethash(j-m*l,j-m*l+l-1);
                mp[y]--;
                if(mp[y]==0)mp.erase(y);
                if(mp.size()==m)ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值