POJ 2236 Wireless Network

题目链接

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

大致题意
第一行给出两个数字 n、d 表示有n台电脑和距离d
接下来给出 n 行,每行表示每台电脑的坐标
之后多组数据(EOF)操作,操作有两种,第一种是O p,表示修理p电脑,修理完之后,p电脑可以与直线距离d以内的电脑连通,两台电脑之间可以直接连通也可以通过第三方电脑连通,但两两电脑之间距离不得超过 d,第二种操作是S p q,表示询问 p 和 q 电脑之间是否连通,这个连通可以是直接连通也可以是间接连通

具体思路
并查集思想,每次修理操作,要将该电脑与 d 距离内的所有电脑并到一个集合里面去,如果已经在里面则不用,否则添加进去,查询时候直接查询两个电脑是否在一个集合之内即可

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
const int maxdot=1050;
int gather[maxdot],repaired[maxdot];
struct node
{
    int x,y;
}dot[maxdot];
void init(int n)
{
    for (int i=1;i<=n;i++)
    {
        gather[i]=i;
        repaired[i]=0;
    }
    return ;
}
bool distance(int one,int other,int d)
{
    if ((dot[one].x-dot[other].x)*(dot[one].x-dot[other].x)+
        (dot[one].y-dot[other].y)*(dot[one].y-dot[other].y)<=d*d)
    {
        return true;
    }
    return false;
}
int findroot(int n)
{
    if (gather[n]==n)
        return n;
    return findroot(gather[n]);
}
void join(int one,int other,int d)
{
    int oneroot=findroot(one),otherroot=findroot(other);
    if (oneroot!=otherroot&&distance(one,other,d))
    {
        gather[otherroot]=oneroot;
    }
    return ;
}
int main()
{
    int n,d;
    scanf("%d %d",&n,&d);
    init(n);
    for (int i=1;i<=n;i++)
    {
        scanf("%d %d%*c",&dot[i].x,&dot[i].y);
    }
    char import;
    while (scanf("%c%*c",&import)!=EOF)
    {
        if (import=='O')
        {
            int p;
            scanf("%d%*c",&p);
            repaired[p]=1;
            for (int i=1;i<=n;i++)
            {
                if (i!=p&&repaired[i]!=0)
                {
                    join(p,i,d);
                }
            }
        }else
        {
            int p,q;
            scanf("%d %d%*c",&p,&q);
            if (findroot(p)==findroot(q))
            {
                printf("SUCCESS\n");
            }else
            {
                printf("FAIL\n");
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值