POJ 1456 Supermarket

添加链接描述

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4
50 2
10 1
20 2
30 1

7
20 1
2 1
10 3
100 2
8 2
5 20
50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

大致题意
多组数据,第一行n,表示一共有n种商品,接下来n行,每行两个数p、d表示当前物品的价格和这个商品必须在d天之内卖出去,每一天你只能卖出一个商品或是不卖,问最后你可以卖出多少钱

具体思路
骚操作,要不是放在并查集里面,我这辈子可能都想不到这么神奇的思路,一开始先按照价格进行从大到小的排序,之后利用类似最大生成树的思想去进行并查集合并,开设一个并查集利用链式前向星的思想把天数给合并起来,一开始初始所有的天数标记是-1,利用最大生成树从大到小进行合并,每次查找当前点之前的日子里是否有某一天是空缺的,如果有进行合并,当日子数到0的时候,表示所有的天数里面都是整体集合最大的数字,将其全部添加求和即可

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<string.h>
#include<queue>
using namespace std;
typedef long long LLD;
const LLD maxnum=1e4+50;
LLD dot[maxnum];
struct node
{
    LLD p,d;
}thing[maxnum];
bool cmp(node x,node y)
{
    return x.p>y.p;
}
LLD findroot(LLD x)
{
    if (dot[x]==-1)
    {
        return x;
    }
    return dot[x]=findroot(dot[x]);
}
int main()
{
    LLD n;
    while (scanf("%lld",&n)!=EOF)
    {
        memset(dot,-1,sizeof(dot));
        for (LLD i=0;i<n;i++)
        {
            scanf("%lld %lld",&thing[i].p,&thing[i].d);
        }
        sort(thing,thing+n,cmp);
        LLD sum=0;
        for (LLD i=0;i<n;i++)
        {
            LLD root=findroot(thing[i].d);
            if (root>0)
            {
                sum+=thing[i].p;
                dot[root]=root-1;
            }
        }
        printf("%lld\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值