1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

题意

给出N个正整数来作为一棵二叉排序树的结点插入顺序,问:这串序列是否是该二叉排序树的先序序列或是该二叉排序树的镜像树的先序序列。所谓镜像树是指交换二叉树的所有结点的左右子树而形成的树(也即左子树所有结点数据域大于或等于根结点,而根结点数据域小于右子树所有结点的数据域)。如果是镜像树,则输出 YES,并输出对应的树的后序序列;否则,输出NO。

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

思路

  1. 构建一颗二叉搜索树,判断其先序序列是否和输入顺序一样
  2. 若一样,输出YES,和后序序列;若不一样,检查其镜像二叉树,其余和1一样
  3. 构造镜像二叉树。
    法一:将原有的二叉搜索树,递归交换左右子树
    法二:再建立一颗树,建立时条件与1.相反
  4. 若镜像树先序和输入一样,输出YES和后序序列;不一样,输出NO,结束

注意

  1. 结尾无空格(PAT习惯)
  2. 插入相同元素时,按习惯是不插入,但这题要求插入到右边

代码

#include<iostream>
using namespace std;
int n, cnt = 0;
int dt[1001], pre_data[1001], post_data[1001];
int flag;
struct Tnode{
	int val;
	Tnode* left;
	Tnode* right;
	Tnode(int x) : val(x), left(NULL), right(NULL){}	//结构体构造函数 
};
/*用引用&方式插入节点,flag=1,正常BST;flag=2,镜像树*/
void Insert(Tnode* &root, int x){
	if(root == NULL){				//查找失败,插入位置
		root = new Tnode(x);
		return ;
	}
	if(flag == 1){
		if(root->val <= x) 
			Insert(root->right, x);//往右走
		else
			Insert(root->left, x);//往左走
	}
	else{							//镜像树 
		if(root->val > x) 
			Insert(root->right, x);//往右走
		else
			Insert(root->left, x);//往左走
	}
}
/*创建树,调用insert()*/
Tnode* Create(){
	Tnode* root = NULL;
	for(int i=0; i<n; i++)
		Insert(root, dt[i]);
	return root;
}
/*先序遍历,对节点的访问是放入pre_data[]里*/
void PreOrder(Tnode* root){
	if(root == NULL)
		return ;
	pre_data[cnt++] = root->val;
	PreOrder(root->left);
	PreOrder(root->right);
}
/*后序遍历,对节点的访问是放入post_data[]里*/
void PostOrder(Tnode* root){
	if(root == NULL)
		return ;
	PostOrder(root->left);
	PostOrder(root->right);
	post_data[cnt++] = root->val;
}
bool Check(Tnode* root){
    for(int i=0; i<n; i++){
        if(dt[i] != pre_data[i])
            return false;		//若先序对不上,退出 
    }
    printf("YES\n");			//若无错,开始后序 
    cnt = 0;
    PostOrder(root);
    for(int i=0; i<n; i++){
        printf("%d", post_data[i]);//输出后序节点,最后不要空格 
        if(i != n-1)
            printf(" ");
    }
    return true;				//这里忘记写,就报了段错误...... 
}
int main(){
	cin >> n;
	for(int i=0; i<n; i++)	//输入数据 
		cin >> dt[i];
	flag = 1;				//建BST树标记 
	Tnode* root1 = Create();//
	PreOrder(root1);
	if(Check(root1)){		//若BST匹配上了,直接返回,就不用建立镜像树了 
		return 0;
	}
	flag = 2;				//建立镜像树标记 
	Tnode* root2 = Create();
	cnt = 0;
	PreOrder(root2);
	if(Check(root2)){		//若BST镜像树匹配上了,直接返回 
		return 0;
	}
	printf("NO\n");			//前面两树先序都匹配失败,输出NO 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值