MGRE实验

搭建MGRE
要求:
1,、R5为ISP只能配置IP地址
2、R1——R3间建立MGRE环境,且使用EIGRP来学习各自环回
3、R4可以正常访问R5的环回
4、R1与R5进行chap认证,R5为主认证方(不基于主机名)
一、拓扑图
在这里插入图片描述
二、实验配置:
配置:
R1配置:
R1#configure terminal
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface s1/0
R1(config-if)#ip address 172.16.0.2 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s1/1
R1(config-if)#ip address 15.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R2配置:
R2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#interface s1/0
R2(config-if)#ip address 25.1.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int
R2(config)#interface loopback 0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R3配置:
R3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#interface s1/0
R3(config-if)#ip address 35.1.1.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R4配置:
R4#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#interface s1/1
R4(config-if)#ip address 172.16.0.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 0
R4(config-if)#ip address 192.168.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R5配置:
R5#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R5(config)#interface s1/0
R5(config-if)#ip address 15.1.1.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface s1/1
R5(config-if)#ip address 25.1.1.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface s1/2
R5(config-if)#ip address 35.1.1.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface loopback 0
R5(config-if)#ip address 5.5.5.5 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

配置中心站点(以R1为中心站点)
R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#interface tunnel 0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#tunnel source serial 1/1
R1(config-if)#tunnel source 15.1.1.1
R1(config-if)#tunnel mode gre multipoint
R1(config-if)#ip nhrp map multicast dynamic
R1(config-if)#ip nhrp network-id 100 //所有站点必须处于同一ID内

分支站点:
R2(config)#interface tunnel 0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#tunnel source s1/1
R2(config-if)#tunnel mode gre multipoint
R2(config-if)#ip nhrp nhs 10.1.1.1
R2(config-if)#ip nhrp map 10.1.1.1 15.1.1.1
R2(config-if)#ip nhrp network-id 100
R2(config-if)#ip nhrp map multicast 15.1.1.1

R3(config)#interface tunnel 0
R3(config-if)#ip address 10.1.1.3 255.255.255.0
R3(config-if)#tunnel source s1/2
R3(config-if)#tunnel mode gre multipoint
R3(config-if)#ip nhrp nhs 10.1.1.1
R3(config-if)#ip nhrp map 10.1.1.1 15.1.1.1
R3(config-if)#ip nhrp network-id 100
R3(config-if)#ip nhrp map multicast 15.1.1.1

起EIGRP协议:
R1(config)#router ei 90
R1(config-router)#no auto-summary
R1(config-router)#network 10.1.1.0
R1(config-router)#network 172.16.0.0

R2(config)#router ei 90
R2(config-router)#no auto-summary
R2(config-router)#network 10.1.1.0
R2(config-router)#network 192.168.2.0
R3(config)#router ei 90
R3(config-router)#no auto-summary
R3(config-router)#network 10.1.1.0
R3(config-router)#network 192.168.3.0

R4(config)#router ei 90
R4(config-router)#no auto-summary
R4(config-router)#network 172.16.0.0
R4(config-router)#network 192.168.4.0
R1(config)#ip route 0.0.0.0 0.0.0.0 15.1.1.2
R1(config)#access-list 1 permit 192.168.4.0 0.0.0.255
R1(config)#access-list 1 permit 172.16.0.0 0.0.255.255
R1(config)#ip nat inside source list 1 interface s1/1 overload
R1(config)#interface s1/1
R1(config-if)#ip nat outside
R1(config-if)#interface s1/0
R1(config-if)#ip nat inside

R1与R5认证(不基于主机名):
主认证方:
R5(config)#interface s1/0
R5(config-if)#encapsulation ppp
R5(config-if)#ppp authentication chap
R5(config-if)#username ccnp password cjc
被认证方:
R1(config)#interface s1/1
R1(config-if)#encapsulation ppp
R1(config-if)#ppp chap password cjc
R1(config-if)#ppp chap hostname ccnp

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值