Common Subsequeue——HDU-1195(动态规划)

1.题目

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Input
abcfbc abfcab
programming contest
abcd mnp
Output
4
2
0
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0

2.题目分析

最长公共子序列
简单的动态规划
画辅助空间在这里插入图片描述
图片出处
总结出:F[i][j]=F[i-1][j-1]+1; (a[i]==b[j])
F[i][j]=max(F[i-1][j],F[i][j-1]) (a[i]!=b[j]);
真正写代码时,dp[i][j]表示str1前i个元素和str2前j个元素中的最长公共子序列,迭代到最后dp[len1][len2]就是答案。

#include<iostream>
#include<cstring> 
#include<algorithm>
using namespace std;


int dp[10005][10005];
char str1[10005],str2[10005];
int l1,l2;//不大明白 好多人喜欢在main外定义 

int main(){
	while(cin>>str1>>str2){ //scanf("%s %s", s1, s2) != EOF
		l1=strlen(str1);
		l2=strlen(str2);
		memset(dp,0,sizeof(dp));
		
    	for(int i=1;i<=l1;i++){
			for(int j=1;j<=l2;j++){
				if(str1[i-1]==str2[j-1]) 
					dp[i][j]=dp[i-1][j-1]+1;
				else
				   dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		cout<<dp[l1][l2]<<endl; 
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值