1096 Consecutive Factors (20 分)
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2
31
).
Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:
630
Sample Output:
3
567
柳婼的答案实在是太巧秒了…
i从2开始,直到开方,进行遍历.
j从i开始,sum=jj+1j+2…
巧妙就巧妙在这里: 对n,若其可以写成连乘形式,n/sum一定是整数!因为连乘就是整数乘出来的嘛…同时跳出循环的条件也确定了:只要n%sum!=0,就可以直接跳出来,而j又是从i开始,所以如果i==j,则说明这个i就不可能满足.遍历得到最长len即可…
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int n; cin>>n;
int max=sqrt(n)+1;
int len=0;
int first=0;
for(int i=2;i<max;i++)
{
int j=i;
int sum=1;
for(j=i;j<max;j++)
{
sum=sum*j;
if(n%sum!=0)
break;
}
if(j-i>len)
{
first=i;
len=j-i;
}
}
if(first==0)
cout << 1 << endl << n;
else
{
cout << len << endl;
for (int i = 0; i < len; i++) {
cout << first + i;
if (i != len - 1) cout << '*';
}
}
return 0;
}