目录
设备的登陆,基础配置
设备的登陆
模式
- Router> 用户模式;第一级别模式;最低级别模式;做部分的查看
- Router# 特权模式,第二级别模式;在该模式下可以对设备进行所有的查看及测试以及一些简单的配置
Router(config)# 全局配置模式,第三级别模式;可以对设备进行管理配置
- Router(config-???)#其他配置模式,第四级别模式;其他配置模式,可以对设备进行各种专用配置
- Router>enable 键入授权
- Router#configure terminal 键入配置终端
Router#exit 一层一层下
- Router#disable 专用于特权模式到用户模式
- Router#End 用于从特权以上模式直接回到特权模式
设备的基础配置
预配指令
Router(config)#line console 0 进入console口
Router(config-line)#logging synchronous 日志同步
Router(config-line)#exec-timeout 0 0 永不超时
Router(config-line)#exit
Router(config)#no ip domain-lookup 关闭域名解析
Router(config)#hostname r1 修改默认主机名
设备的加密配置
进入console口密码
- r1(config)#line console 0 进入console 口
r1(config-line)#password ****(密码) 配置登录密码
r1(config-line)#login 表示确认
用户模式到特权模式的密码
- r1(config)#enable password ***(密码)
建议的加密方式
从用户到特权模式的密码
- r1(config)#enable secret ***(密码)
登录console口密码
- r1(config)#username ccna privilege 1 secret cisco321(密码)
r1(config)#username ccnp privilege 15 secret cisco321 (密码,与上面一致)
r1(config)#line console 0
r1(config-line)#login local
r1#write 保存
查询指令
- r1#show running-config 查看运行配置文档;显示设备当下所运行的所有命令
- show running config 显示所有的配置
- show versin 显示版本号和寄存器值
- show ip route 查看路由表
- show protocols 显示出所有的被动路由协议和接口上哪些协议被设置
- show ip protocols 显示了被配置在路由器上的路由选择协议,同时给出了在路由选择协议中使用的定时器等信息
- show ip eigrp neighbors 查看邻居表
- show ip eigrp topology 查看拓扑表
- show ip eigrp traffic 查看发送包数量
- show ip ospf 显示OSPF的进程号和ROUTER-ID
- show user 查看SW的在线用户
- show ip interface brief 查看接口的谪要信息
- show startup config 查看NVRAM中的配置信息
- show interface+接口类型+接口号查看接口管理性
- show controllers interface 查看接口是否有DCE电缆
- show history 查看历史记录
- show terminal 查看终端记录大小
基础配置
配IP地址
r1(config)#interface fastEthernet 0/0 进入接口
r1(config-if)#ip address 192.168.1.1 255.255.255.0 配置接口的ip地址
r1(config-if)#no shutdown 开启接口
配DHCP
配置
-
r1(config)#ip dhcp pool ccna 创建名为ccna的池塘
-
r1(dhcp-config)#network 192.168.1.0 255.255.255.0 关联接口
-
r1(dhcp-config)#default-router 192.168.1.1 网关地址
-
r1(dhcp-config)#dns-server 114.114.114.114 dns服务器地址
-
r1(dhcp-config)#exit 退出
排除地址
排除单个地址
- r1(config)#ip dhcp excluded-address 192.168.1.1 排除192.168.1.1这个网段
排除一段地址
- r1(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.5 排除从192.168.1.1到192.168.1.5这一段地址
静态路由
出接口写法
- Router(config)#ip route 192.168.2.0 255.255.255.0 f0/0
前缀 目标网段(未知网段) 出接口
下一跳写法
- Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
前缀 目标网段(未知网段) 下一跳
扩展配置
环回接口 环回地址
Router(config)#interface loopback 0 打开环回接口
Router(config-if)#ip address 1.1.1.1 255.255.255.0 书写地址
缺省路由
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.97
前缀 表示全网段 下一跳
路由汇总
Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.1.34
前缀 汇总网段 子网掩码 下一跳
.路由黑洞
- 一种现象
空接口路由
Router(config)#ip route 192.168.0.0 255.255.252.0 null 0
汇总路由 子网掩码 指向null 0
浮动静态路由
-
Router(config)#ip route 192.168.0.0 255.255.252.0 21.1.1.2 2
RIP(距离矢量路由协议)基本设置
配置RIP
RIPV1(不常用)
r1(config)#router rip 启动协议
r1(config-router)#version 1 选择版本1
r1(config-router)#network 172.16.0.0 宣告自身网段
RIPV2(常用)
r1(config)#router rip
r1(config-router)#version 2选择版本2
r1(config-router)#no auto-summary 关闭自动汇总
r1(config-router)#network 1.0.0.0 宣告
扩展配置
RIPV2的认证
r1(config)#key chain xxx
r1(config-keychain)#key 1
r1(config-keychain-key)#key-string cisco123 邻居间必须一致
r1(config)#interface s1/1
r1(config-if)#ip rip authentication key-chain xxx
r1(config-if)#ip rip authentication mode md5 模式也必须一致
RIPV2的手工汇总
r2(config)#interface s1/0
r2(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0
被动接口
r1(config)#router rip
r1(config-router)#passive-interface loopback 0
加快收敛
r1(config)#router rip
r1(config-router)#timers basic 15 90 90 120 按比例修改
缺省路由
r3(config)#router rip
r3(config-router)#default-information originate
OSPF(开放式最短路径优先协议)配置
OSPF的配置
r1(config)#router ospf 1 启动时需要配置进程号,仅具有本地意义
r1(config-router)#router-id 1.1.1.1 配置RID,要求为全网唯一
r1(config-router)#network 1.1.1.1 0.0.0.0 area 0 宣告RID
r1(config-router)#network 12.1.1.0 0.0.0.255 area 0 宣告自身网段
自身网段 反掩码 区域
修改参考带宽
r1(config)#router ospf 1
r1(config-router)#auto-cost reference-bandwidth 1000 整个网络所有设备均需要修改一致
修改接口优先级
r1(config)#interface fastEthernet 0/0
r1(config-if)#ip ospf priority 3 修改接口优先级
r1#clear ip ospf proces
Reset ALL OSPF processes? [no]: yes
OSPF的扩展配置
认证
明文认证
- r1(config)#interface s1/1 进接口
- r1(config-if)#ip ospf authentication message-digest 先开启认证服务
- r1 (config-if)#ip ospf authentication-key 1 *****(密码) 明文认证
密文认证
- r1(config)#interface s1/1 进接口
- r1(config-if)#ip ospf authentication message-digest 先开启认证服务
- r1(config-if)#ip ospf message-digest-key 1 md5 ****(密码) 密文认证
区域的明文认证
Router(config)#router ospf 100
Router(config-router)#area 0 authentication
区域的密文认证
- Router(config)#router ospf 100
- Router(config-router)#area 0 authentication message-digest
加快收敛
- r1(config)#interface s1/1 进端口
- r1(config-if)#ip ospf hello-interval 5 修改本端的hello time,本端的dead time自动4倍关系匹配
被动接口
- r2(config)#router ospf 1
- r2(config-router)#passive-interface loopback 0
缺省路由
- r4(config)#router ospf 1
- r4(config-router)#default-information originate always
EIGRP(增强内部网关路由协议)配置
EIGRP的配置
- r1(config)#router eigrp 90 此处理解为全网一致的进程号
- r1(config-router)#no auto-summary 关闭自动汇总
- r1(config-router)#network 1.0.0.0 像rip一样直接配置主类
- r1(config-router)#network 124.1.1.1 0.0.0.0 像OSPF一样使用反掩码进行匹配,两者均可
修改接口参考带宽
- r3(config)#interface s1/1
- r3(config-if)#bandwidth 800 修改接口参考带宽
修改差异值
- r3(config)#router eigrp 90
- r3(config-router)#variance 2
EIGRP的扩展配置
认证
- r2(config)#key chain a
- r2(config-keychain)#key 1
- r2(config-keychain-key)#key-string cisco123
- r2(config)#interface s1/1
- r2(config-if)#ip authentication key-chain eigrp 90 a
- r2(config-if)#ip authentication mode eigrp 90 md5
- 注:EIGRP仅支持MD5认证,故在没有修改模式前,认证是无意义的
手工汇总
- r3(config)#interface s1/0
- r3(config-if)#ip summary-address eigrp 90 3.3.2.0 255.255.254.0
- 汇总配置完成后,在汇总设备上将自动产生指向汇总地址的空接口防环路由
被动接口
- r3(config)#router eigrp 90
- r3(config-router)#passive-interface loopback 0
- 用于连接用户的接口,不能用于连接邻居的接口
加快收敛
- r3(config)#interface s1/1
- r3(config-if)#ip hello-interval eigrp 90 5
- r3(config-if)#ip hold-time eigrp 90 15
缺省路由
- r1(config)#interface fastEthernet 0/0
- r1(config-if)#ip summary-address eigrp 100 0.0.0.0 0.0.0.0