Big Number n!的位数(数学)

Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48946 Accepted Submission(s): 23968

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19
思路:这道题目的大概意思就是要你求n!的位数,纯数学的题目,只要知道了公式就很快知道解题方法。

Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta

#include<bits/stdc++.h>
using namespace std;

int main()
{
    int T;
    cin >> T;
    int N;
    double sum;
    while (T--)
    {
        cin >> N;
        sum = 0;
        for (int i = 1; i <= N; i++)
        {
            sum += log10(i);
        }
        cout << (int)sum + 1 << endl;
    }
    return 0;
}

#include<bits/stdc++.h>

using namespace std;
int main()
{
    int t;cin>>t;
    while(t--){
        int n;cin>>n;
        double w = 0;
        for(int i=1;i<=n;i++)
        {
            w=w+log10(i);
        }
        cout<<int(w+1)<<endl;
    }
    return 0;
}

下面介绍两种方法直接求阶乘结果的位数:
方法一
可以将n!表示成10的次幂,即n!=10^M(10的M次方)则不小于M的最小整数就是 n!的位数,对该式两边取对数,有 M =log10^n!
即:
M = log10^1+ log10^2+ log10^3…+ log10^n
循环求和,就能算得M值,该M是n!的精确位数

方法二
利用斯特林(Stirling)公式的进行求解。下面是推导得到的公式:
res=(long)( (log10(sqrt(4.0*acos(0.0)n)) + n(log10(n)-log10(exp(1.0)))) + 1 );
当n=1的时候,上面的公式不适用,所以要单独处理n=1的情况!
有关斯特林(Stirling)公式及其相关推导,这里就不进行详细描述,
这种方法速度很快就可以得到结果。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值