(她是唯一)Radar Installation POJ - 1328

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

 
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
#include<iostream>
#include<cmath>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct cartesian
{
    ///笛卡尔坐标系建立
    double left, right;///海岛势力范围与海岸截得的区间,double型是因为有开根号
} coast[1000]; ///海岸
bool cmp(cartesian  a, cartesian  b)
{
    return a.left<b.left;
}///按左端点从小到达排序
int main()
{
    int n, d, i,x,y;
    int Case = 0;
    while(cin>>n>>d&&n&&d)
    {
        int sum = 1;///之所以从一开始是因为在存在的情况下会有刚好只有一个相切的情况
        ///相当于一个特殊情况
        for(i=0; i<n; i++)
        {
            cin>>x>>y;///海岛的位置
///这两个用笔自己画一下,就很容易理解:
///逆向思维,本题关键所在,雷达的范围也是海岛的的范围,只需要找到
///海岛在海岸上确立的区间,找最少的点使得每个区间至少有一点
            coast[i].left = x - sqrt(d*d-y*y);
            coast[i].right = x + sqrt(d*d-y*y);
            if(y>d|| d<=0 || y<0)
                sum = -1;
///没有交点,内部雷达(距离为负),海岛在陆地上哈哈哈哈哈都要返回不存在的-1
        }
        sort(coast,coast+n, cmp);
///求左端点排序,再让每一个岛的区间范围不断地和下一个岛求交集,
///有则使交集继续与下一个岛求交集,无则岛数加一,下一个无交集的岛为起始继续
        double min=coast[0].right;
        for(i=1; i<n&&sum!=-1; i++)
        {
            if(coast[i].right<=min)///区间包含
                min=coast[i].right;///把被包含的区间作为开始
            else if(min<coast[i].left)
            {///此区间和上一个区间不相交
                min=coast[i].right;///再从下一个区间开始
                sum++;///找到一个了鸭!!!
            }
        }///按格式输出
        printf("Case %d: %d\n", ++Case, sum);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值