poj 1742 Coins(多重背包和二进制优化)

题目戳这里=-=
Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 48420 Accepted: 16282
Description

People in Silverland use coins.They have coins of value A1,A2,A3…An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output

8
4
Source

LouTiancheng@POJ

题目大意:用给定的硬币可以表示给定的范围类有多少个数。
题解:普通的多重背包用二进制优化即可,如果给定的硬币面值和张数的乘积大于给定的范围就直接完全背包就好了。

下面就是代码啦

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <stack>
using namespace std;
const int maxn = 1e5+100;
const int inf = 0x3f3f3f3f;
const int mod = 10000;
typedef long long ll;
int n,m;
int s[250],c[250];
int dp[maxn];
inline int read()
{
    int x=0;char ch=getchar();
    while(ch<'0'||ch>'9')ch=getchar();
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x;
}
int main()
{
    while(~scanf("%d %d",&n,&m)){
        if(n==m&&m==0)break;
        for(int i=1;i<=n;i++){
            s[i]=read();
        }
        for(int i=1;i<=n;i++){
            c[i]=read();
        }
        memset(dp,-inf,sizeof(dp));
        dp[0]=0;
        for(int i=1;i<=n;i++){
            if(c[i]*s[i]<m){
                int num=c[i];
                for(int k=1;num>0;k<<=1){
                    if(k>num)k=num;
                    num-=k;
                    for(int j=m;j>=s[i]*k;j--){
                        if(dp[j-s[i]*k]+s[i]*k>dp[j]) //这里绝对不能用max函数用了就是超时,我的一个下午就在这个上面了。
                            dp[j]=dp[j-s[i]*k]+s[i]*k;
                    }
                }
            }
            else{
                for(int j=s[i];j<=m;j++){
                    if(dp[j-s[i]]+s[i]>dp[j]){
                        dp[j]=dp[j-s[i]]+s[i];
                    }
                }
            }
        }
        int ans=0;
        for(int i=1;i<=m;i++){
            if(dp[i]>0){
                //cout<<i<<' '<<dp[i]<<endl;
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值