Mondriaan's Dream (状压DP)

题目连接:戳这里鸭
Mondriaan’s Dream
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 24262 Accepted: 13430
Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0
Sample Output

1
0
1
2
3
5
144
51205
Source

Ulm Local 2000

题目大意:让我们用长为2宽为1的矩形来组成长为w宽为h的矩形,问有多少中方法。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn = 100010;
const int maxn2= 47711;
const int inf =0x3f3f3f3f;
const int mod = 10007;
int n,m;
ll dp[15][1<<12];
bool cheak(int s)
{
    int cnt=0;
    for(int i=0;i<m;i++){
        if(s&1){
            if(cnt&1)return 0;
        }
        else cnt++;
        s>>=1;
    }
    if(cnt&1) return 0;
    return 1;
}
int main()
{
    while(~scanf("%lld%lld",&n,&m),n+m){
        memset(dp,0,sizeof(dp));
        if((n*m)&1){ cout<<0<<endl;  continue;}
        for(int i=0;i<(1<<m);i++)  if(cheak(i)) dp[1][i]=1;
        for(int i=2;i<=n;i++){
            for(int j=0;j<(1<<(m));j++){
                for(int k=0;k<(1<<(m));k++){
                    if(!(j&k)&&cheak((k^j))) //注意这一步必须(j&k)在前面不然就会超时
                        dp[i][j]+=dp[i-1][k];
                }
            }
        }
        printf("%lld\n",dp[n][0]);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值