PAT1001

46 篇文章 0 订阅

原题

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题解

这个题难倒是不难, 就是感觉题目没讲清楚,有点坑。

题意:输入两个数,计算和,从个位开始,每三位输出一个 ","

代码:

#include <algorithm>
#include <iostream>
#include <string>

using namespace std;

int main() {
  int a, b;
  cin >> a >> b;
  int c = a + b;
  if (c < 0) {
    cout << "-";
    c = -c;
  }
  string temp = to_string(c);
  int size = temp.size();
  int cnt = 0;
  string str = "";
  for (int i = size - 1; i >= 0; --i) {
    if (cnt == 3) {
      cnt = 0;
      str = "," + str;
    }
    ++cnt;
    str = temp[i] + str;
  }
  cout << str << endl;
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值