PAT1009

46 篇文章 0 订阅

原题

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 … N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

思路

这就是多项式的乘法,翻译请看 PAT1002

题解

#include <algorithm>
#include <cmath>
#include <iostream>
#include <map>
#include <set>
#include <string>
#include <unordered_map>
#include <unordered_set>
#include <vector>

using namespace std;

int main() {
  // exp是指数, coe是系数
  int n, m, exp;
  float coe;
  map<int, float> mp1;
  map<int, float> mp2;
  cin >> n;
  for (int i = 0; i < n; ++i) {
    cin >> exp >> coe;
    mp1[exp] = coe;
  }
  cin >> m;
  for (int i = 0; i < m; ++i) {
    cin >> exp >> coe;
    mp2[exp] = coe;
  }
  map<int, float, greater<int>> mp;
  map<int, float>::iterator it1;
  map<int, float>::iterator it2;
  for (it1 = mp1.begin(); it1 != mp1.end(); ++it1) {
    for (it2 = mp2.begin(); it2 != mp2.end(); ++it2) {
      int exp = it1->first + it2->first;
      float coe = it1->second * it2->second;
      if (mp[exp] == 0) {
        mp[exp] = coe;
      } else {
        mp[exp] += coe;
      }
    }
  }
  map<int, float, greater<int>>::iterator it;
  int ans = 0;
  for (it = mp.begin(); it != mp.end(); ++it) {
    if (fabs(it->second - 0.0) < 0.000001) {
      ++ans;
    }
  }
  cout << ans;
  for (it = mp.begin(); it != mp.end(); ++it) {
    if (fabs(it->second - 0.0) < 0.000001) {
      continue;
    }
    printf(" %d %.1f", it->first, it->second);
  }
  cout << endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值