Candies POJ-3159--最短路

Time Limit: 1500MS Memory Limit: 131072K

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.


题目大意:有N个人,让你求第一个人和第n个人的得到的糖果的最大差距。输入为a,b,c表示a认为b最多比他多c个糖果。

。。。看了一会儿题目,这不就是一个裸的最短路吗。。。假设a到b有很多路,我们必须选择最短的那一条,因为这样才能满足所有的猜测条件,这相当于取一个交集吧。。。于是这一题就没了,写个堆优化的Dij+前向星建图。。。一发就A了,没什么坑点。。。

以下是AC代码:

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int inf = 1e8 + 10;
int n, m;
const int mac = 1e5 + 10;
struct node
{
	int to, w, next;
};
struct ns
{
	int id, d;
	bool operator<(const ns& a)const {
		return d > a.d;
	}
};
node eg[mac << 1];
int head[mac], dis[mac], num = 0, vis[mac];
void add(int u, int v, int w);
void Dij();
int main()
{
	scanf("%d%d", &n, &m);
	int u, v, w;
	memset(head, -1, sizeof(head));
	for (int i = 1; i <= m; i++) {
		scanf("%d%d%d", &u, &v, &w);
		add(u, v, w );
	}
	Dij();
	return 0;
}
void add(int u, int v, int w)
{
	eg[++num].to = v; eg[num].w = w; eg[num].next = head[u];
	head[u] = num;
}
void Dij()
{
	for (int i = 1; i <= n; i++) dis[i] = inf;
	memset(vis, 0, sizeof(vis));
	dis[1] = 0;
	priority_queue<ns>q;
	ns p;
	p.id = 1, p.d = 0;
	q.push(p);
	while (!q.empty()) {
		ns now = q.top();
		q.pop();
		int u = now.id;
		if (vis[u]) continue;
		vis[u] = 1;
		for (int i = head[u]; i != -1; i = eg[i].next) {
			int v = eg[i].to, w = eg[i].w;
			if (dis[v] > now.d + w) {
				dis[v] = now.d + w;
				ns p;
				p.d = now.d + w; p.id = v;
				q.push(p);
			}
		}
	}
	printf("%d\n", dis[n]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值