Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90
问题简述:
每一次输入两个16进制的数字,将其相加后输出。
程序说明:
十六进制的数需要六十四位读入,所以用__int64读入,读入、输出是添加hex表示是十六进制,因为十六进制不能直接输出负数,所以需要判断和是否为负数,若是负数,就再取其绝对值,在输出前加一个负号输出。因为十六进制的输出都是小写,所以添加uppercase将其大写。
#include<iostream>
using namespace std;
int main()
{
_int64 a, b;
while (cin >> hex >> a >>b)
{
b = a + b;
if (b < 0)
{
cout << '-';
b = -b;
}
cout << uppercase << hex << b << endl;
}
return 0;
}