第二次周赛Problem D

https://cn.vjudge.net/contest/275894#problem/D
D - Problem D
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3

题解:
题目要求输入一个数,每个数根相加,若加起来是各位数,则输出;若不是个位数,则继续相加。
一开始想到的就是先把每个数拆开相加,判断是否大于等于10,若大于等于10,则再执行上述操作,先把每个数拆开再相加,再判断,这样子就增加了运行时间,所以以下是代码time limit:

#include<iostream>
using namespace std;
int main()
{
	int n, p;
	while (1)
	{
		cin >> n;
		if (n == 0)
			break;
		p = n;
	A:		int s = 0;
		int k;
		while (p)
		{
			k = p % 10;
			s = s + k;
			p=p / 10;
		}
			if (s < 10)
			{
				printf("%ld", s);
				printf("\n");
			}
		else {
			p = s;
			goto A;
		}
	}
}

后来参考了别人的做法,考虑到输入的数有可能很大,所以可以选择字符串类型或者字符数组类型都可以,先用s把每个数之和存起来,然后可以用余9的方法,可以发现,当一个数(除9的公倍数)余9后等到的数就是原来的数每个个位数相加,若这个数是9的公倍数最后结果一定是9。

以下是AC代码:

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string a;
	while (cin >> a && a != "0")
	{
		int s = 0;
		for (int i = 0; i < a.size(); i++)
			s = s + (a[i]-'0');
		if (s < 10)
			cout << s << endl;
		else if (s % 9 == 0)
			cout << "9" << endl;
		else cout << s % 9 << endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值