HDU-1009(FatMouse' Trade)

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

题目大意

有多个测试样例,每一个测试样例一开始输入m和n表示老鼠的钱数
后面接n行(表示有n个地方可以用于交换)每一行由j和f两个数组成,表示可以用f数量的钱换j数量的食物
要求换最多的食物(可以部分交换,不必将每一个地方的食物换完)

解题思路

由于可以部分购买(交换)那么问题就没有背包问题那么复杂了
只需要将每一个地方的交换比率按降序排列,从上到下交换就行

AC代码

#include<algorithm>
#include<iostream>
#include<vector>
#include<cstdio>
using namespace std;
struct node
{
    int earn;
    int pay;
    double value;
};
vector<node> ss;
bool cmp(node &a,node &b)
{
    return a.value>b.value;
}
int main()
{
    int m,n;
    while(cin>>m>>n)
    {
        if(m==-1&&n==-1)
            break;
        double num=0;
        int i;
        node new_;
        for(i=0; i<n; ++i)
        {
            cin>>new_.earn>>new_.pay;
            new_.value=1.0*new_.earn/new_.pay;
            ss.push_back(new_);
        }
        sort(ss.begin(),ss.end(),cmp);
        i=0;
        while(m>0&&i<n)
        {
            if(ss[i].pay<=m)
            {
                m-=ss[i].pay;
                num+=ss[i].earn;
            }
            else
            {
                num+=ss[i].value*m;
                break;
            }
            ++i;
        }
        printf("%.3f\n",num);
        ss.clear();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值