HDU 2005 第几天 (模拟)

Description

给定一个日期,输出这个日期是该年的第几天。

Input

输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

Output

对于每组输入数据,输出一行,表示该日期是该年的第几天。

Sample Input

1985/1/20
2006/3/12

Sample Output

20
71

代码

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<vector>
#include<stdio.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int judge(int x)
{
    if(x%4==0&&x%100!=0||x%400==0)
        return 1;
    return 0;
}
int main()
{
    int a,b,c;
    while(~scanf("%d/%d/%d",&a,&b,&c))
    {
        int run=judge(a);
        int ans=0;
        switch(b)
        {
            case 12:ans+=30;
            case 11:ans+=31;
            case 10:ans+=30;
            case 9:ans+=31;
            case 8:ans+=31;
            case 7:ans+=30;
            case 6:ans+=31;
            case 5:ans+=30;
            case 4:ans+=31;
            case 3:ans+=28+run;
            case 2:ans+=31;
            case 1:ans+=c;
        }
        printf("%d\n",ans);
    }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值