Climbing Worm

Climbing Worm

问题链接

http://acm.hdu.edu.cn/showproblem.php?pid=1049

Problem Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input

10 2 1
20 3 1
0 0 0

Sample Output

17
19

问题简叙

一英寸的蠕虫在井的底部有n英寸深。它有足够的能量每分钟爬升u英寸,但在再次攀爬之前,它必须休息一分钟。在剩下的时间里,它滑倒了d英寸。爬山和休息的过程,然后重复。蠕虫爬出井还有多长时间?我们总是把一分钟的一部分算成一分钟,如果蠕虫刚爬到井底的顶部,我们就假设蠕虫会爬出来。

问题分析

每次输入后先判断输入的n是否为0,为否再接着判断u是否大于等于n,若是输出1,否就进行如下循环:以每一分钟增加u每一分钟减少d计算位移和s与时间和i,当n-s=<u时退出循环,将时间i加上1即为结果。

AC代码

 #include<iostream>
using namespace std;
int main()
{
    int n,u,d;
	while(cin>>n>>u>>d)
	{
	int i=0,s=0;	
	if(n==0)break;
	if(u>=n)cout<<1<<endl;
	else
	{
	while(n-s>u)
	{
	s+=u;i++;
	s-=d;i++;
	}
	i++;	
	cout<<i<<endl;	
	}
    }
	return 0;	
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值