A + B Problem II

A + B Problem II

问题链接

http://acm.hdu.edu.cn/showproblem.php?pid=1002

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

问题分析

用高精度加法计算:用字符串储存输入的数字,再倒序储存在整型数组中,再按加法原理对数组处理。注意空格问题。

AC代码

#include<iostream> 
#include<cstdio> 
#include<cstring> 
using namespace std;
int main()
{
	char a1[1001], b1[1001];
	int a[1001], b[1001], c[1001];
	int s1, s2, s3, i, x, n, k=0;
	cin >> n;
	while (n)
	{
		k++;
		n--;
		memset(a, 0, sizeof(a));
		memset(b, 0, sizeof(b));
		memset(c, 0, sizeof(c));
		cin >> a1;
		cin >> b1;
		s1 = strlen(a1);
		s2 = strlen(b1);
		for (i = 0; i <= s1 - 1; i++)
		{
			a[s1 - i] = a1[i] - 48;
		}
		for (i = 0; i <= s2 - 1; i++)
		{
			b[s2 - i] = b1[i] - 48;
		}
		s3 = 1;
		x = 0;
		while (s3 <= s1 || s3 <= s2)
		{
			c[s3] = a[s3] + b[s3] + x;
			x = c[s3] / 10;
			c[s3] = c[s3] % 10;
			s3++;
		}
		c[s3] = x;
		if (c[s3] == 0)
		{
			s3--;
		}
		cout << "Case " << k << ":" << endl;
		cout << a1 << " + " << b1 << " = ";
		for (i = s3; i >= 1; i--)
		{
			cout << c[i];
		}
		cout << endl;
		if (n > 0)cout << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值