最大子序列和

7-1 最大子列和问题 (20分)
给定K个整数组成的序列{ N1, N2 , …, NK },“连续子列”被定义为{ N​i​​ , N​i+1, …, N​j },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

本题旨在测试各种不同的算法在各种数据情况下的表现。各组测试数据特点如下:

数据1:与样例等价,测试基本正确性;
数据2:102个随机整数;
数据3:103个随机整数;
数据4:104个随机整数;
数据5:105个随机整数;
输入格式:
输入第1行给出正整数K (≤100000);第2行给出K个整数,其间以空格分隔。

输出格式:
在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:
6
-2 11 -4 13 -5 -2
输出样例:
20

int MaxSubSum(int A[], int N){
    int sum = 0, MaxSum = 0;
    for(int i = 0; i < N; i++){
        sum += A[i];
        MaxSum = max(sum, MaxSum);
        if(sum < 0) sum = 0;//如果sum<0,则说明前面这段带来了负面效应,因此要重置
    }
    return MaxSum;
}

拓展
7-1 Maximum Subsequence Sum (25分)
Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

#include <bits/stdc++.h>
using namespace std;

int a[100005];
int main(){
    int n;
    cin >> n;
    int sum = 0, l = 0, r = 0, ans_l = 0, ans_r = 0;
    //考虑负数和零 && 全为负数 的情况下,输出的应该为0 0 0,因此max_sum 初始化 -1
    int max_sum = -1;
    for(int i = 0; i < n; i++){
        cin >> a[i];
        sum += a[i];
        if(sum > max_sum){//结果区域发生变化
            max_sum = sum;
            ans_r = i;
            ans_l = l;
        }else if(sum < 0){
            sum = 0;
            l = i + 1;//上界发生变化
        }
    }
   
    if(max_sum < 0){ //都是负数的情况
        cout << "0" << " " << a[0] <<" " << a[n-1] << endl;
    }else{
        cout << max_sum <<" "<< a[ans_l]<< " "<< a[ans_r] << endl;
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值