C - Heavy Transportation

C - Heavy Transportation

his giant steel crane to the place where it is needed on which all streets can carry the weight.

Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem

You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input
    
  
   The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
  

    Output
    
  
   The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
  

    Sample Input
    1

3 3
1 2 3
1 3 4
2 3 5

    Sample Output
    Scenario #1:

4

提示:此题为求最短路径的最大权值(应该是这样)

代码一为出错了的代码
代码二为AC代码(就该动了一点)

1、

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define inf 0x3f3f3f3f

using namespace std;

int a,b;
int n[1010][1010];
int disv[1010];
int flag[1010];

void bigboom()
{
    int i,j,k;
    for(i=1; i<=b; i++)
    {
        disv[i]=n[i][1];
    }
    flag[1]=1;
    for(i=1; i<b; i++)
    {
        int g=0;
        int h;
        for(j=1; j<=b; j++)
        {
            if(flag[j]==0&&disv[j]>g)
            {
                g=disv[j];
                h=j;
            }
        }
        flag[h]=1;
        if(h==b)
        {
            break;
        }
        for(k=1; k<=b; k++)
        {
            if(flag[k]==0&&disv[k]<min(disv[h],n[k][h]))
            {
                disv[k]=min(disv[h],n[k][h]);
            }
        }
    }
    printf("%d\n",disv[b]);
}

int main()
{
    int T,t=0;
    scanf("%d",&T);
    while(T--)
    {
        t++;
        scanf("%d%d",&b,&a);
        memset(n,0,sizeof(n));
        memset(flag,0,sizeof(flag));
        memset(disv,0,sizeof(disv));
        int u,v,w;
        while(a--)
        {
            scanf("%d%d%d",&u,&v,&w);
            if(n[u][v]<w)
            {
                n[u][v]=n[v][u]=w;
            }
        }
        printf("Scenario #%d:\n",t);
        bigboom();
    }
    return 0;
}

2、(就把cin改成scanf就AC了)(AC代码)

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#define inf 0x3f3f3f3f

using namespace std;

int a,b;
int n[1010][1010];
int disv[1010];
int flag[1010];

void bigboom()
{
    int i,j,k;
    for(i=1; i<=b; i++)
    {
        disv[i]=n[i][1];
    }
    flag[1]=1;
    for(i=1; i<b; i++)
    {
        int g=0;
        int h;
        for(j=1; j<=b; j++)
        {
            if(flag[j]==0&&disv[j]>g)
            {
                g=disv[j];
                h=j;
            }
        }
        flag[h]=1;
        if(h==b)
        {
            break;
        }
        for(k=1; k<=b; k++)
        {
            if(flag[k]==0&&disv[k]<min(disv[h],n[k][h]))
            {
                disv[k]=min(disv[h],n[k][h]);
            }
        }
    }
    printf("%d\n\n",disv[b]);
}

int main()
{
    int T,t=0;
    scanf("%d",&T);
    while(T--)
    {
        t++;
        scanf("%d%d",&b,&a);
        memset(n,0,sizeof(n));
        memset(flag,0,sizeof(flag));
        memset(disv,0,sizeof(disv));
        int u,v,w;
        while(a--)
        {
            scanf("%d%d%d",&u,&v,&w);
            if(n[u][v]<w)
            {
                n[u][v]=n[v][u]=w;
            }
        }
        printf("Scenario #%d:\n",t);
        bigboom();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值