数据结构上机测试2-2:单链表操作B

数据结构上机测试2-2:单链表操作B

			Time Limit: 1000 ms
			Memory Limit: 65536 KiB
							
			
				Submit
				Statistic
				Discuss
			
			Problem Description
			
			按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。				
			Input
			
			第一行输入元素个数n;

第二行输入n个整数。
Output

			第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。
Sample Input

				10

21 30 14 55 32 63 11 30 55 30

			Sample Output
			
				10

30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

#include <iostream>

using namespace std;

struct node
{
    int data;
    struct node *next;
};

void output(node *h)//输出
{
    node *p;
    for(p=h->next; p!=NULL; p=p->next)
    {
        if(p->next==NULL)
        {
            cout << p->data << endl;
        }
        else
        {
            cout << p->data << " ";
        }
    }
}

int creat(node *h,int m)//删除
{
    node *p,*q,*t;
    p=h->next;
    while(p)
    {
        t=p->next;
        q=p;
        while(t)
        {
            if(p->data==t->data)
            {
                q->next=t->next;
                m--;
                t=t->next;
            }
            else
            {
                q=q->next;
                t=t->next;
            }
        }
        p=p->next;
    }
    return m;
}

int main()
{
    int a,i,x;
    node *h,*p;
    h=new node;
    h->next=NULL;
    cin >> a;
    for(i=1; i<=a; i++)//建表
    {
        p=new node;
        cin >> p->data;
        p->next=h->next;
        h->next=p;
    }
    cout << a << endl;
    output(h);
    x=creat(h,a);
    cout << x << endl;
    output(h);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值