Lowest Bit

Problem Description

			Given an positive integer A (1 <= A <= 100), output the lowest bit of A. 

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
Input

			Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.				
			Output
			
			For each A in the input, output a line containing only its lowest bit.				
			Sample Input
			
				26

88
0

			Sample Output
			
				2

8

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n,n)
    {
        cout<<(n&-n)<<endl;
    }
}

#include <stdio.h>
#include <string.h>
int set(int n)
{
    char str[10000];
    int k = 0;
    while(n)
    {
        int r = n%2;
        str[k++] = r+'0';
        n/=2;
    }
    str[k] = '\0';
    int i;
    for(i = 0;i<k;i++)
    {
        if(str[i]=='1')
        break;
    }
    return i;
}
int pow(int n)
{
    int s = 1;
    for(int i = 1;i<=n;i++)
    s*=2;
    return s;
}
int main()
{
    int n,k;
    while(~scanf("%d",&n),n)
    {
        k = set(n);
        k = pow(k);
        printf("%d\n",k);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值