L - Can you raed it croretcly?

Do you feel weird when reading the problem title? You can understand word meanning correctly even if its spelling is wrong. 
According to research, if the initial and last letter of the word are right, and just swap the others, human can correct the spelling of the word automatically. 
Now, giving you a word and its correct spelling, can you correct it automatically? 

Input

The input contains several test cases. 
Each test case consists of one line with two strings, each string only contains lowercase letter, and its length is no more than 20. 

Output

Output "Equal" when the two strings are same; output "Yes" when you can correct it, otherwise outoput "No". 

Sample Input

raed read
it it
croretcly correctly
raed dear

Sample Output

Yes
Equal
Yes
No
#include <iostream>
#include <bits/stdc++.h>
#include <string.h>
using namespace std;

int main()
{
    char n[25],m[25];
    int a,b,s[200],ss[200],i;
    while(cin >> n >> m)
    {
        memset(s,0,sizeof(s));
        memset(ss,0,sizeof(ss));
        a=strlen(n);
        b=strlen(m);
        if(n[0]==m[0]&&n[a-1]==m[b-1])
        {
            if(strcmp(n,m)==0)
            {
                cout << "Equal" << endl;
            }
            else
            {
               for(i=1;i<=a-2;i++)
               {
                  s[n[i]]++;
               }
               for(i=1;i<=b-2;i++)
               {
                  ss[m[i]]++;
               }
               for(i=97;i<=97+32;i++)
               {
                   if(s[i]!=ss[i])
                   {
                       break;
                   }
               }
               if(i!=97+33)
               {
                   cout << "No" << endl;
               }
               else
               {
                   cout << "Yes" << endl;
               }
            }
        }
        else
        {
            cout << "No" << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值