D - Genealogical tree POJ - 2367 (拓扑排序)

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

题意:有n个人,编号1~n,然后输入n行,第i行有一些编号,这些编号代表第i个人的后代,每行输入以0结束。然后按照辈分输出这些编号

题并不难,拓扑排序的模板题,但是输出格式有点坑

AC代码:


//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/
//https://www.cnblogs.com/zzrturist/    //博客园
//https://blog.csdn.net/qq_44134712     //csdn

using namespace std;
const int N=1e3+10;
typedef long long ll;
const int mod=1e9+7;

priority_queue<int,vector<int>,greater<int> >q;
int a[N][N];
int vis[N];
int n;

void tuopu(){
   for(int i=1;i<=n;i++){
      if(!vis[i]){
          q.push(i);
      }
   }
   int cnt=1;
   while(!q.empty()){
      int t=q.top();
      q.pop();
      if(cnt!=n){
        cout << t << " ";
        cnt++;
      }
      else{
        cout << t;
      }
      for(int i=1;i<=n;i++){
        if(!a[t][i]){
            continue;
        }
        else{
            vis[i]--;
        }
        if(!vis[i]){
            q.push(i);
        }
      }
   }
}

int main(){
    cin >> n;
    memset(a,0,sizeof(a));
    memset(vis,0,sizeof(vis));
    int x;
    for(int i=1;i<=n;i++){
        for(int j=1;;j++){
            cin >> x;
            if(x==0){
                break;
            }
            a[i][x]=1;
            vis[x]++;
        }
    }
    tuopu();
    return 0;
}

//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/
//https://www.cnblogs.com/zzrturist/    //博客园
//https://blog.csdn.net/qq_44134712     //csdn

using namespace std;
const int N=1e3+10;
typedef long long ll;
const int mod=1e9+7;

int a[N][N];
int vis[N];
int n;

void tuopu(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(vis[j]==0){
                vis[j]--;
                cout << j;
                for(int k=1;k<=n;k++){
                    if(a[j][k]==1){
                        a[j][k]--;
                        vis[k]--;
                    }
                }
                if(i!=n){
                    cout << " ";
                }
                break;
            }
        }
    }
}

int main(){
    cin >> n;
    memset(a,0,sizeof(a));
    memset(vis,0,sizeof(vis));
    int x;
    for(int i=1;i<=n;i++){
        for(int j=1;;j++){
            cin >> x;
            if(x==0){
                break;
            }
            a[i][x]=1;
            vis[x]++;
        }
    }
    tuopu();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZZ --瑞 hopeACMer

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值