Unbutu使用apt install **报Package ** has no installation candidate错误

例:执行ifconfig(ip查询命令)
在这里插入图片描述
此时控制台要求安装net-tools

	输入安装命令:apt install net-tools

在这里插入图片描述
原因:系统缺少安装相关软件的包,需要更新软件源

	执行:sudo apt-get update
			
	apt-get命令一般需要root权限执行,所以一般跟着sudo命令

在这里插入图片描述
更新完成后,重新执行安装命令即可

tips:安装软件源时
	1:检查该软件源是否有其它依赖包
	2:没有依赖包正常安装完成即可使用,有依赖包需要下载依赖包
	(相当于maven中的依赖问题)

可能会出现的问题:某些依赖包无法正常安装
此时输入命令:sudo apt-get install -f 即可正常完成全部安装
-f : (--fix-broken的简写)尝试修正系统依赖损坏处 
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页