PAT basic 1044 火星数字 (20分) 测试点 1 2 4错误原因及解释

一、题目描述

火星人是以 13 进制计数的:

地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam

输出样例:
hel mar
may
115
13

二、代码

//1044
#define _CRT_SECURE_NO_WARNINGS
#include<stdlib.h>
#include<string>
#include<cctype>
#include<stack>
#include<iostream>
using namespace std;
string a[13] = {
	"tret","jan", "feb", "mar",
	"apr", "may", "jun", "jly",
	"aug", "sep", "oct", "nov", "dec" };

string b[13] = {
	"tret","tam", "hel","maa",
	"huh", "tou", "kes", "hei",
	"elo", "syy", "lok", "mer", "jou"
};


void earth2mars(string n)
{
	long x = stol(n);
	//将10进制数字转为13进制
	bool count = 0;
	int temp;
	stack<int>s;
	if (x == 0)
	{
		cout << a[0]<<endl;
		return ;
	}
	while (x > 0)
	{
		s.push(x % 13);
		x /= 13;
	}
	while (s.size() > 1)
	{
		if (count)
			cout << " ";
		cout << b[s.top()];
		s.pop();
		count++;
	}
	if (count&&s.top()!=0)
		cout << " " << a[s.top()];
	else
		if(s.top()!=0)
		cout << a[s.top()];




	cout << endl;
}

void mars2earth(string n)
{
	//处理字符串得到对应的数字
	long re = 0;
	int i = 0;
	string temp;
	for (; i < n.size() - 3; i += 4)
	{
		temp = n.substr(i, 3);
		if (temp == "tre")
			temp += "t";
		for (int j = 0; j < 13; j++)
		{
			if (b[j] == temp)
			{
				re *= 13;
				re += j;
				break;
			}
		}
	}
	temp = n.substr(i, 3);
	if (temp == "tre")
		temp += "t";
	for (int j = 0; j < 13; j++)
	{
		if (a[j] == temp)
		{
			re *= 13;
			re += j;
			break;
		}
		else if (b[j] == temp)
		{
			re *= 13;
			re += j;
			re *= 13;
			break;
		}
	}
	cout << re << endl;
}

int main()
{
	int n;
	cin >> n;
	getchar();
	string temp;
	for (int i = 0; i < n; i++)
	{
		getline(cin, temp);
		if (isalpha(temp[0]))
			mars2earth(temp);
		else
			earth2mars(temp);
	}


	system("pause");
	return 0;
}

三、测试点错误原因

  • 测试点1 考察的是输入数字0 能否正常打印
  • 测试点2 4 考察的是如果包含到了整除这个情况,比如十进制的130,转成13进制应该是A0表示,但由于火星数字十位有单独的表达方式,故不需要个位0占位,所以如果只剩一个个位0是不需要翻译的。
题目合集

在这里呦~

  • 5
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值