HDU-1074(状压DP)

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

题目大意:Ignatius需要做N门功课,每门功课都有一个截止时间和持续的时间,然后如果Ignatius有功课的完成时间超过了它的截止时间,那么就会被扣分,现在问Ignatius怎样做完这n门功课才能让扣分最少,第一行输出最小的扣分,后面n行输出方案,如果两种方案扣分相同,那么就输出字典序最小的那个。
解题思路:状压DP,对于每种状态,枚举下一门应该做什么作业,和上一门应该做什么作业,这样就解决了最小扣分的问题了,接下来我们要解决方案字典序的问题了,因为题目已经说明了数据给出时是按照字典序从小到大给出的,而且n<=15,那么我们就可以使用hash的做法, 把字符串看出一个15进制的数,然后如果扣分相等,就去最小的hash值就可以啦。
代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <bitset>
using namespace std;
#define int long long
const int maxn = 3e5 + 7;
const int inf = (1ll*1<<60);
int dp[20][56000],pre[20][56000];
char arr[20][200];
struct node
{
    int d,c;
}e[20];
bitset<16>s,l,tmp;
int res[20];
signed main()
{
    int t;
    scanf("%lld",&t);
    while(t--){
        int n;
        scanf("%lld",&n);
        for(int i=0;i<n;i++){
            for(int j=0;j<(1<<n);j++){
                pre[i][j]=0;dp[i][j]=inf;
            }
        }
        for(int i=0;i<n;i++){
            scanf("%s",arr[i]);
            scanf("%lld%lld",&e[i].d,&e[i].c);
            dp[i][1<<i]=max(e[i].c-e[i].d,1ll*0);
            pre[i][1<<i]=i;
        }
        for(int k=1;k<(1<<n);k++){
            s=k;
            int sum=0;
            for(int i=0;i<n;i++){
                if(s[i]==1)sum+=e[i].c;
            }
            for(int j=0;j<n;j++){
                l=1<<j;
                if((s&l).any())continue;
                unsigned long long x=(s|l).to_ullong();
                //cout<<"x="<<x<<endl;
                for(int i=0;i<n;i++){
                    if(s[i]==0)continue;
                    if(dp[j][x]>dp[i][k]+max(sum+e[j].c-e[j].d,1ll*0)){
                        dp[j][x]=dp[i][k]+max(sum+e[j].c-e[j].d,1ll*0);
                        pre[j][x]=pre[i][k]*15+j;
                    }
                    if(dp[j][x]==dp[i][k]+max(sum+e[j].c-e[j].d,1ll*0)){
                        pre[j][x]=min(pre[j][x],pre[i][k]*15+j);
                    }
                }
            }
        }
        int ans=inf,x=(1<<n)-1,u;
        for(int i=n-1;i>=0;i--){
            if(ans>dp[i][x]){
                ans=dp[i][x];
                u=i;
            }
        }
        printf("%lld\n",ans);
        int len=n;
        memset(res,0,sizeof res);
        while(pre[u][x]){
            res[len--]=pre[u][x]%15;
            pre[u][x]/=15;
        }
        for(int i=1;i<=n;i++){
            printf("%s\n",arr[res[i]]);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值