HDU 1711(KMP)

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题目大意:在序列a中找到一段连续的子序列与序列b相等,输出最早的一段,如果没有就输出-1。

解题思路:套KMP的板子就可以了。PS:昨天晚上本来写了很多,但是突然网卡,卡退了,再进来的时候已经没了,就没写了。

大家可以去看这个博客:KMP算法(研究总结,字符串)

代码:

#pragma GCC optimize(2)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <bitset>
#include <queue>
//#include <random>
#include <time.h>
using namespace std;
#define int long long
#define ull unsigned long long
#define ls root<<1
#define rs root<<1|1
const int maxn=1e4+10;
const int maxm=1e6+10;
//std::mt19937 rnd(time(NULL));
int to[maxn],a[maxm],b[maxn],n,m;
void init()
{
    to[1]=0;
    for(int i=2;i<=m;i++){
        int t=to[i-1];
        while(t && b[t+1]!=b[i])t=to[t];
        if(b[t+1]==b[i])to[i]=t+1;
        else to[i]=0;
    }
}

int kmp()
{
    init();
    int i=1,j=1;
    while(i<=n){
        if(a[i]==b[j]){
            i++,j++;
            if(j==m+1){
                return i-m;
            }
        }
        else{
            if(j==1) i++;
            else j=to[j-1]+1;
        }
    }
    return -1;
}
signed main()
{
    int t;
    scanf("%lld",&t);
    while(t--){
        scanf("%lld%lld",&n,&m);
        for(int i=1;i<=n;i++){
            scanf("%lld",a+i);
        }
        for(int i=1;i<=m;i++)scanf("%lld",b+i);
        printf("%lld\n",kmp());
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值