HDU 3746(KMP)

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:
在这里插入图片描述

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题目大意:给出一个字符串,问我们最少需要加多少个字符才可以让整个字符串是被一个字符串循环两次或以上得到的。
解题思路:KMP算法中的next数组可以表示为 前缀和后缀相等的最大长度。我们处理之后,next数组存的是这个字符串前缀和后缀相等的最大长度。
而如果一个字符串s是由另一个字符串t循环x次得到的,那么就肯定预处理next数组之后我们可以知道next[s.len-1]的最大长度为(x-1)t.len,所以我们用总长度s.len=xt.len-(x-1)*t.len就可以得到最小的循环节了。
代码:

#pragma GCC optimize(2)
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <bitset>
#include <queue>
//#include <random>
#include <time.h>
using namespace std;
#define int long long
#define ull unsigned long long
#define ls root<<1
#define rs root<<1|1
const int maxn=1e6+10;
const int maxm=3e6+10;
//std::mt19937 rnd(time(NULL));
int to[maxn],len1,len2;
char a[maxn];
void init()
{
    to[0]=-1;
    for(int i=1;a[i]!='\0';i++){
        int t=to[i-1];
        while(t>=0 && a[t+1]!=a[i])t=to[t];
        if(a[t+1]==a[i])to[i]=t+1;
        else to[i]=-1;
    }
}
signed main()
{
    int t,test=1;
    scanf("%lld",&t);
    while(t--){
        scanf("%s",a);
        init();
        int ans,len=strlen(a);
        int x=len-to[len-1]-1;
        if(len%x==0){
            if(to[len-1]==-1) printf("%lld\n",len);
            else puts("0");
        }
        else printf("%lld\n",x-len%x);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值