D - Disastrous Doubling Kattis - disastrousdoubling

D - Disastrous Doubling

题意:1个细菌一小时分裂一次,每次分裂后都会做实验取走一部分细菌,问最后剩多少细菌(mod 1e9+7)。

思路:ans = (ans*2%mod-a[i]%mod+mod)%mod 但是这样出来的一定是正数,无法判断error的情况,所以要标记一个取的数的最大值,如果ans超过了这个值,那么就不会出现负数了。
A scientist, E. Collie, is going to do some experiments with bacteria. Right now, she has one bacterium. She already knows that this species of bacteria doubles itself every hour. Hence, after one hour there will be 2 bacteria.

E. Collie will do one experiment every hour, for n consecutive hours. She starts the first experiment exactly one hour after the first bacterium starts growing. In experiment i she will need bi bacteria.

How many bacteria will be left directly after starting the last experiment? If at any point there are not enough bacteria to do the experiment, print “error”.

Since the answer may be very large, please print it modulo 109+7.

Input
The input consists of two lines.

The first line contains an integer 1≤n≤105, the number of experiments.

The second line contains n integers b1,…,bn, where 0≤bi≤260 is the number of bacteria used in the ith experiment.

Output
Output a single line containing the number of bacteria that remains after doing all the experiments, or “error”.

Sample Input 1 Sample Output 1
3
0 0 0
8
Sample Input 2 Sample Output 2
5
1 1 1 1 1
1
Sample Input 3 Sample Output 3
5
0 2 2 4 0
0
Sample Input 4 Sample Output 4
5
0 2 2 4 1
error

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define maxn 100005
#define mo 1000000007
ll a[maxn];

int main()
{
    ios::sync_with_stdio(0);
    int n;
    cin >> n;
    ll maxx = 0;
    for(int i =0; i < n; i ++)
    {
        cin >> a[i];
        maxx = max(maxx, a[i]);
    }
    int f = 0;
    ll num = 1;
    maxx*=2;
    for(int i = 0; i < n; i ++)
    {
        if(f)
        {
           num = (num*2%mo-a[i]%mo+mo)%mo;
        }
        else
        {
            num*=2;
            if(num>=maxx) f = 1;
            num-=a[i];
            if(num<0)
            {
                cout <<"error"<<endl;
                return 0;
            }
        }
    }
    cout << num%mo << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值