1043 输出PATest (20 分)

给定一个长度不超过 10^4的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest… 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出

输入格式:

输入在一行中给出一个长度不超过 10^4的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

思路:
P, A, T, e, s, t分别存储对应字符,最后循环输出,每输出一个删除一个字符,当所有字符为空推出循环!
其实用char和int[]做会更好~

题解:

#include<iostream>
#include<string>

using namespace std;

int main() {
	ios::sync_with_stdio(false);
	string str, P, A, T, e, s, t;
	getline(cin, str);
	for (int i = 0; i < str.length(); i++) {
		if (str[i] == 'P') P += 'P';
		if (str[i] == 'A') A += 'A';
		if (str[i] == 'T') T += 'T';
		if (str[i] == 'e') e += 'e';
		if (str[i] == 's') s += 's';
		if (str[i] == 't') t += 't';
	}
	while (P.length() || A.length() || T.length() || e.length() || s.length() || t.length())
	{
		if (P.length()) P.erase(P.begin()), cout << "P";
		if (A.length()) A.erase(A.begin()), cout << "A";
		if (T.length()) T.erase(T.begin()), cout << "T";
		if (e.length()) e.erase(e.begin()), cout << "e";
		if (s.length()) s.erase(s.begin()), cout << "s";
		if (t.length()) t.erase(t.begin()), cout << "t";
	}

	return 0;
}

优化:

#include<iostream>
#include<string>

using namespace std;

int main() {
	ios::sync_with_stdio(false);
	string str;
	int P = 0, A = 0, T = 0, e = 0, s = 0, t = 0;
	getline(cin, str);
	for (int i = 0; i < str.length(); i++) {
		if (str[i] == 'P') P++;
		if (str[i] == 'A') A++;
		if (str[i] == 'T') T++;
		if (str[i] == 'e') e++;
		if (str[i] == 's') s++;
		if (str[i] == 't') t++;
	}
	while (P || A || T || e || s || t)
	{
		if (P) P--, cout << "P";
		if (A) A--, cout << "A";
		if (T) T--, cout << "T";
		if (e) e--, cout << "e";
		if (s) s--, cout << "s";
		if (t) t--, cout << "t";
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值