Recursive sequence ---矩阵快速幂

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
Sample Input
2
3 1 2
4 1 10
Sample Output
85
369

Hint
In the first case, the third number is 85 = 21十2十3^4.
In the second case, the third number is 93 = 2
1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

先根据题意得到递推公式即:f(n)=2*f(n-2)+f(n-1)+i^4
然后在构建那个矩阵(直接构建就行了),剩下的就是套模板了
下面是推导那个矩阵过程
在这里插入图片描述
在这里插入图片描述

ac代码:

#include<iostream>
#include<cstdio> 
#include<cstring>
using namespace std;
typedef long long ll;
const ll mod=2147493647;//根据题意进行mod 
struct node{
	ll p[10][10];
};
int n=7;
node q(node a,node b)
{//两个矩阵相乘。 
	node ans;
	memset(ans.p,0,sizeof(ans.p));
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			for(int k=1;k<=n;k++){
				ans.p[i][j]=(ans.p[i][j]+a.p[i][k]*b.p[k][j]%mod+mod)%mod;
			}
		}
	}
	return ans;
}
node p(node a,ll nn)
{//快速幂 
	node res;
	memset(res.p,0,sizeof(res.p));
	for(int i=1;i<=n;i++)res.p[i][i]=1;
	while(nn){
		if(nn&1)res=q(res,a);
		nn>>=1;
		a=q(a,a);
	}
	return res;
}
int main()
{
	node a;
	memset(a.p,0,sizeof(a.p));//清空为0,下面是对a数组进行赋值初始化 
	a.p[1][2]=1;
	a.p[2][1]=2;a.p[2][2]=1;a.p[2][3]=1;a.p[2][4]=4;a.p[2][5]=6;a.p[2][6]=4;a.p[2][7]=1;
	a.p[3][3]=1;a.p[3][4]=4;a.p[3][5]=6;a.p[3][6]=4;a.p[3][7]=1;
	a.p[4][4]=1;a.p[4][5]=3;a.p[4][6]=3;a.p[4][7]=1;
	a.p[5][5]=1;a.p[5][6]=2;a.p[5][7]=1;
	a.p[6][6]=1;a.p[6][7]=1;
	a.p[7][7]=1;
	int t;
	cin>>t;
	while(t--)
	{
		node b;
		ll k,aa,bb;
		scanf("%lld%lld%lld",&k,&aa,&bb);
		if(k==1){//特殊情况 
			printf("%d\n",aa);
			continue;
		}
		if(k==2){//特殊对待 
			printf("%d\n",bb);
			continue;
		}
		node ans=p(a,k-2); 
		memset(b.p,0,sizeof(b.p));
		b.p[1][1]=aa;b.p[2][1]=bb;b.p[3][1]=16;b.p[4][1]=8;
		b.p[5][1]=4;b.p[6][1]=2;b.p[7][1]=1; 
		ans=q(ans,b);//注意顺序 ,反了就不对了 
		printf("%lld\n",ans.p[2][1]);//我的f(n)是在第二行,所以要输出ans.p[2][1]。 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值