并查集

模板:

int find(int u)
{
	while(u!=parent[u])
	{
		parent[u]=parent[parent[u]];
		u=parent[u];
	}
	return u;
}
void Uion(int a,int b)
{
	int x,y;
	x=find(a);
	y=find(b);
	if(x!=y)
	{
		parent[x]=y;
	}
}
int find(int u)
{
	while(u!=parent[u])
	{
		parent[u]=parent[parent[u]];
		u=parent[u];
	}
	return u;
}
void Uion(int a,int b)
{
	int x,y;
	x=find(a);
	y=find(b);
	if(x!=y)
	{
		if(t[a]>t[b])//t集合代表i分支集合的高度
		{
			parent[b]=a;
		}
		else
		{
			parent[a]=b;
			if(t[a]==t[b])
			{
				t[b]++;
			}
		}
	}
}

例题1:畅通工程
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
Sample Input
4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0
Sample Output
1
0
2
998
思路:通过并查集来判断有n个不相交的集合,最少需要建n-
条边,才可以其相交;

#include<iostream>
#include<cstdio>
using namespace std;
int m,n,parent[1010],trail[1010];
int find(int u)
{
	while(u!=parent[u])
	{
		parent[u]=parent[parent[u]];
		u=parent[u];
	}
	return u;
}
void union_(int x,int y)
{
	int a,b;
	a=find(x);
	b=find(y);
	if(a!=b)
	{
			parent[b]=a;

	}
}
int main()
{
	while(scanf("%d",&n),n)
	{
		for(int i=1;i<=n;i++)
		{
			parent[i]=i;
		}
		scanf("%d",&m);
		int a,b;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			union_(a,b);
		}
		int cnt=0;
		for(int j=1;j<=n;j++)
		{
			if(parent[j]==j)
			cnt++;
		}
		cout<<cnt-1<<endl;
	}
	
	return 0;
}

例题2:
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
思路:
通过坐标可以得到点与点之间的距离,最开始全部机器都是坏的(全部赋初值为0),如果输入‘O’代表机器p修好的,给其赋值为1;然后通过点与点之间的距离和是否修好来通过并查集来判断机器之间是否可以到达;

#include<cstdio>
#include<cmath>
#include<string.h>
#include<iostream>
using namespace std;
int n,d,p[1010];
double map[1010][1010],V[1010];
bool vis[1010];

struct node{
	int x,y;
}e[1010];
void distance()//求点与点之间的距离
{
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=n;j++)
		{
			int x=e[i].x-e[j].x;
			int y=e[i].y-e[j].y;
			map[i][j]=sqrt((double)(x*x+y*y));
		}
	}
}
int find(int u)
{
	while(u!=p[u])
	{
		p[u]=p[p[u]];
		u=p[u];
	}
	return u;
}
void one()//当输入O的时候执行
{
	int t;
	scanf("%d",&t);
	if(vis[t])
		return;
	vis[t]=1;//1代表该机器已经修好
	for(int i=1;i<=n;i++)
	{
		if(map[t][i]<=d&&vis[i])
		{
			int fy=find(i),fx=find(t);
			p[fy]=fx;	//使得可以到达的机器拥有一个共同的父亲,然后通过判断他们的父亲是否一样,来是否可以到达
		}
	}
}
void two()//当输入S时执行
{
	int a,b;
	scanf("%d%d",&a,&b);
	if(find(a)==find(b))
	{
		printf("SUCCESS\n");
	}
	else{
		printf("FAIL\n");
	}
}

int main()
{
	memset(vis,false,sizeof(vis));
	memset(map,0x3f,sizeof(map));
	scanf("%d%d",&n,&d);
	for(int i=1;i<=n;i++)
	{
		map[i][i]=0;
		p[i]=i;
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&e[i].x,&e[i].y);
	}
	distance();
	char num[2];
	while(~scanf("%s",num))
	{
		switch(num[0])
		{
			case 'O':
			{
				one();
				break;
			} 
			case 'S': 
			{
				two();
				break;
			}	
		}		
	}
	return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值