HDU1093

A+B for Input-Output Practice (V)

java

  • Problem Description
    Your task is to calculate the sum of some integers.

  • Input
    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

  • Output
    For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

  • Sample Input
    2
    4 1 2 3 4
    5 1 2 3 4 5

  • Sample Output
    10
    15

import java.util.Scanner;
public class Main{
	public static void main(String[] args){
		Scanner input = new Scanner(System.in);
		int x = input.nextInt();    //输入接下来的数据组数
		for(int i = 1; i <= x; i++){
			int y = input.nextInt();    //输入一组中有多少个数
			int []a = new int[100];    //定义数组储存一组数据中的y个数
			int sum = 0;
			for(int j = 0;j<y;j++){
				a[j] = input.nextInt();    //将输入的y个数放到数组中
				sum += a[j];    //对y个数求和
			}
			System.out.println(sum);    //打印结果
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值