POJ2676---Sudoku 数独(dfs)

                                                          Sudoku

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 28480 Accepted: 12987 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task. 

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

利用计算机实现数独,解决了小时候的一大难题呀

数独的规则:9x9的棋盘上原本就有一些数字,不能改变,往剩余的空格(这道题用0表示)里面填数字(1-9),确保

这一行数字不能重复出现&&这一列数字不能重复出现&&这一个3x3的小棋盘里数字不能重复出现

根据规则填满整个棋盘并输出,输出任意一种完整的数独棋盘即可

类似于棋盘问题和n皇后问题,使用数组来标记,这里使用的是三个 二维数组

第几个方框的计算方法可以根据规律找出 第x行y列:  k=(x-1)/3*3+(y-1)/3+1

int row[mm][mm];//标记第 i行是否出现过数字 j 
int col[mm][mm];//标记第 i列是否出现过数字 j 
int cell[mm][mm];//标记第 i个方框里是否出现过数字 j 

每一次搜索用来枚举一个位置,dfs行优先,9行全部放完即OK,注意判断区分能不能放并随时标记

注意输入和输出,没有空格。。。。

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
inline int _read() {
    char ch = getchar();
    int sum = 0;
    while (!(ch >= '0' && ch <= '9'))ch = getchar();
    while (ch >= '0' && ch <= '9')sum = sum * 10 + ch - 48, ch = getchar();
    return sum;
}
const int inf=0x3f3f3f3f;
const int mm=11;

char Mp[mm][mm];//输入棋盘  
int mp[mm][mm];//目标棋盘 
int row[mm][mm];//标记第 i行是否出现过数字 j 
int col[mm][mm];//标记第 i列是否出现过数字 j 
int cell[mm][mm];//标记第 i个方框里是否出现过数字 j 

bool dfs(int x,int y){
	if(x==10)
		return true;//over  
	if(mp[x][y]!=0)//不能放 往后 
		if(y==9)
			return dfs(x+1,1);//到头了,放下一行 
		else 
			return dfs(x,y+1);//没到头,放下一个 
	else{
		int k=(x-1)/3*3+(y-1)/3+1;
		for(int i=1;i<=9;i++){//枚举数字  
			if(row[x][i]||col[y][i]||cell[k][i])
				continue;
			mp[x][y]=i;
			row[x][i]=col[y][i]=cell[k][i]=1;
			bool flag;
			if(y==9)
				flag=dfs(x+1,1);
			else 
				flag=dfs(x,y+1);
			if(flag)
				return flag;//成功了 return OK 
			mp[x][y]=0;
			row[x][i]=col[y][i]=cell[k][i]=0;
		} 	
	} 
	return false;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		for(int i=0;i<mm;i++)
			for(int j=0;j<mm;j++)
				mp[i][j]=row[i][j]=col[i][j]=cell[i][j]=0;
		for(int i=1;i<=9;i++){
			scanf("%s",Mp[i]+1);
			for(int j=1;j<=9;j++){
				mp[i][j]=Mp[i][j]-'0';
				if(mp[i][j]){
					row[i][mp[i][j]]=1;
					col[j][mp[i][j]]=1;
					int pos=(i-1)/3*3+(j-1)/3+1;
					cell[pos][mp[i][j]]=1;
				}
			}
		}
		dfs(1,1);
		for(int i=1;i<=9;i++){
			for(int j=1;j<=9;j++)
				printf("%d",mp[i][j]);
			printf("\n");
		}	
	}	
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值