POJ-1251 Jungle Roads(最小生成树)

单击即可传送至poj

请看题:

                                                                                Jungle Roads

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36160 Accepted: 16952

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 
 

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

题目依旧是那么长,废话总是那么多,但是看到上面的图片就什么都晓得了——最小生成树啊!

这是一个暑假的晚上,实验室就还剩我自己,看到题目的输入有点蒙圈,第一次接触这样的题目,本来想去网上找一篇博客看一下怎么输入赶紧给他a点就回宿舍睡觉呢,正好看到群里有人还在学习,我就咬了咬牙,死撑了下来,可能是因为太急着想回去,把变量名写错了,样例都没过去,,woc,,越想回去越掉链子,还好机智的我一点点的的给他调出来了。

最小生成树的板子套上即可,没有什么要说的,唯一注意的就是输入路径的信息

没看网上的博客,不知道大家怎么写的,这个方法可能有点笨,希望有大佬给我提个更好的建议   Orz

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mm=75;

//下面全是板子
struct node{
	int sta,end;
	int len;
}pp[mm];
int cmp(node x,node y){
	return x.len<y.len;
}

int tree[mm]; 
void init(){
	for(int i=1;i<mm;i++)
		tree[i]=i;
}
int find(int x){
	if(tree[x]==x) return x;
	else return tree[x]=find(tree[x]);
}
int merge(int x,int y){
	int t1=find(x);
	int t2=find(y);
	if(t1!=t2){
		if(t1>t2)
			tree[t1]=t2;
		else tree[t2]=t1;
		return 1;
	}
	return 0;
}

int t,n;
char c,s;
int main()
{
	while(scanf("%d",&t)!=EOF&&t){
		init();
		t--;
		int num=0;
		while(t--){//本道题的难点 
			cin>>c>>n;
			for(int i=0;i<n;i++){
				cin>>s>>pp[num].len;
				pp[num].sta=c-'A'+1;
				pp[num].end=s-'A'+1;
				num++;
			}	
		}
		int sum=0;
		sort(pp,pp+num,cmp);//看清哪个是数组长度!!!
//		for(int i=0;i<num;i++)
//			cout<<pp[i].sta<<' '<<pp[i].end<<' '<<pp[i].len<<endl;
		for(int i=0;i<num;i++){
			if(merge(pp[i].sta,pp[i].end)){
				sum+=pp[i].len;
			}
		}
		cout<<sum<<endl; 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值