Legal or Not HDU-3342(拓扑排序判断是否有环)

点击送你到杭电tuopu

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13580    Accepted Submission(s): 6366


 

Problem Description

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

 

 

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

 

 

Output

For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

 

 

Sample Input

 

3 2

0 1

1 2

2 2

0 1

1 0

0 0

 

Sample Output

 

YES

NO

一堆母牛还要搞清关系是否合法???那么费劲干嘛啊

题目就是说 A是B的主人,B是C的主人 ,C是A的主人,关系乱套了,这就是不合法,如果是线性关系就合法

很简单,就是通过拓扑排序判断一下关系中是否有环就OJBK了

怎么判断是否有环呢?

只需要在排序过程中记录一下入度为零的点的个数,要是少于总个数,必成环无疑

其实写这篇blog的原因不是为了这道题,而是为了一道提升版,看了那道题这个题就是zz

那道题戳这里,说句实在的,这个进阶版的我也不会做。。。只能去找了我们协会伟大的丁教主,教主就是流批,写的博客也是极其的好,不敢盗版,只好在这里插入链接,算是引用一下吧,希望教主不要找我收专利费☺

→→→Sorting It All Out (拓扑排序是否有环是否严格有序)←←←

 

附上这道题水一般的代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int mm=105;
int map[mm][mm];
int rudu[mm];

int tuopu(int n){//拓扑排序的板子 
	int cnt=0;//记录入度为0的点的个数 
	queue<int>q;
	for(int i=0;i<n;i++)
		if(rudu[i]==0){
			q.push(i);
			cnt++;
		}
	while(!q.empty()){
		int t=q.front();
		q.pop();
		for(int i=0;i<n;i++){
			if(map[t][i]==0)
				continue;
			rudu[i]--;
			if(rudu[i]==0){
				q.push(i);
				cnt++;
			}
		}
	}
	if(cnt<n)return 0;//个数小于点的总个数 ==有环 
	return 1;
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF){
		if(n==0&&m==0)break; 
		memset(rudu,0,sizeof(rudu));
		memset(map,0,sizeof(map));
		int x,y;
		while(m--){
			scanf("%d%d",&x,&y);
			if(map[x][y]==1)
				continue;
			map[x][y]=1;
			rudu[y]++;
		} 	
		
		if(tuopu(n))printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值