New Year Candles

题目描述

Vasily the Programmer loves romance, so this year he decided to illuminate his room with candles.

Vasily has a candles.When Vasily lights up a new candle, it first burns for an hour and then it goes out. Vasily is smart, so he can make b went out candles into a new candle. As a result, this new candle can be used like any other new candle.

Now Vasily wonders: for how many hours can his candles light up the room if he acts optimally well? Help him find this number.

输入格式:

The single line contains two integers, a and b (1≤a≤1000;2≤b≤1000).

输出格式:

Print a single integer − the number of hours Vasily can light up the room for.

样例输入: 4 2 样例输出: 7

题目的意思就是给你a个蜡烛,每个蜡烛可以点亮一个小时,而消耗每b个蜡烛,可以换一个新的蜡烛,重新点亮一个小时。这道题没什么好说的,就是单纯的模拟,但是我竟然没有立马做出来,还是太菜了

代码如下:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include <iostream>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn=1e6+10;
int read(){
    int x=0,f=1;char ch=getchar();
    while (ch<'0' || ch>'9'){if (ch=='-')f=-1;ch=getchar();}
    while ('0'<=ch && ch<='9'){x=(x<<3)+(x<<1)+(ch^48);ch=getchar();}
    return x*f;
}
int a,b,ans=0,cnt=0;
int main(){
 cin >> a >> b;
 while(a--){
  ans++;
  cnt++;
  if(cnt%b==0){
   cnt=0;
   a++;
  }
 }
 printf("%d",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值