POJ 1426 Find The Multiple找倍数

问题

题目链接
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

分析

题意:

本题的题意:给出一个数,让你求出一个n % m的倍数,并把它输出。它的这个倍数只能由0和1组成

题解:

直接套用dfs 模板,注意我们只需要搜索到一个可行值就行了,所以找到一个就可以不用继续往下搜索了。所以使用了一个标记 flag变量。

AC代码

#include <iostream>

using namespace std;

typedef unsigned long long ll;

ll n;
ll result;
int flag;        //找到标记,找到一个就不用往后面找 

void dfs(ll m, int n, int c){ 
	if(flag) return;
	if(m % n == 0) {
		result = m;
		flag = 1;    
		return ;
	}
	if(c > 19) return ;
	
	dfs(m*10,n,c+1);
	dfs(m*10+1,n,c+1);
} 

int main(){
	while(1){
		cin>>n;
		if(n == 0) return 0;
		
		flag = 0;
		result = 0;
		dfs(1,n,1);  // 参数意义 从 1 开始,n 我们的输入, 1 现在只有1位 
		cout<<result<<endl; 	
	}
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值