求绝对值最大值
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
求n个整数中的绝对值最大的数。
Input
输入数据有2行,第一行为n,第二行是n个整数。
Output
输出n个整数中绝对值最大的数。
Sample Input
5
-1 2 3 4 -5
Sample Output
-5
取绝对值函数为 abs
头文件为 #include<math.h>
代码
#include<stdio.h>
#include<math.h>
int main()
{
int n,i,m,max=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&m);
if( abs(m) > abs(max) )
max=m;
}
printf("%d",max);
return 0;
}