快速排序c++代码
给定你一个长度为 n 的整数数列。
请你使用快速排序对这个数列按照从小到大进行排序。
并将排好序的数列按顺序输出。
输入格式
输入共两行,第一行包含整数 n。
第二行包含 n 个整数(所有整数均在 1∼109 范围内),表示整个数列。
输出格式
输出共一行,包含 n 个整数,表示排好序的数列。
数据范围
1≤n≤100000
输入样例:
5
3 1 2 4 5
输出样例:
1 2 3 4 5
写了好几遍的代码,最终只有这个版本能过。
洛谷地址
https://www.luogu.com.cn/problem/P1177)
ACWing地址
https://www.acwing.com/problem/content/787/
#include <iostream>
using namespace std;
const int N =100005;
int n;
int a[N];
void quick_sort(int arr[],int l,int r){
if(l>=r)
return;
int x=arr[(l+r+1)/2];
int i=l-1,j=r+1;
while(i<j){
do i++; while(arr[i]<x);
do j--; while(arr[j]>x);
if(i<j){
swap(arr[i],arr[j]);
}
}
quick_sort(arr,l,i-1);
quick_sort(arr,i,r);
}
int main(){
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
quick_sort(a,0,n-1);
for(int i=0;i<n;i++)
printf("%d ",a[i]);
return 0;
}