1036 Boys vs Girls (25 point(s))
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF −gradeM . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.
Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
题目大意
给出N个学生的name,gender,id,grade,找出女生中的最高分和男生中的最低分,如果没有女生或者没有男生,则在对应行输出Absent,并在第3行输出NA,否则输出name,id,如果既有男生也有女生,则在第3行输出该女生分数与该男生分数的差值
解题思路
话不多说,水题一个,代码如下
代码
#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
struct info {
char name[12];
char gender;
char id[12];
int score;
}F, M, tmp;
int main()
{
M.score = 101;
F.score = -1;
int N, i;
int ret = scanf("%d", &N);
for (i = 0; i < N; ++i) {
ret = scanf("%s %c %s %d", &tmp.name, &tmp.gender, &tmp.id, &tmp.score);
if (tmp.gender == 'M') {
if (tmp.score < M.score) {
M = tmp;
}
}
else {
if (tmp.score > F.score) {
F = tmp;
}
}
}
if (F.score == -1) printf("Absent\n");
else printf("%s %s\n", F.name, F.id);
if (M.score == 101) printf("Absent\n");
else printf("%s %s\n", M.name, M.id);
if (F.score == -1 || M.score == 101)
printf("NA\n");
else printf("%d\n", F.score - M.score);
return 0;
}