1037 Magic Coupon (25 point(s))
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
题目大意
给定若干张优惠券,其面值代表翻倍数,随后给出若干商品价格,二者数值均有正有负,正优惠券遇上正价格商品,则商店返二者乘积金额,否则你付给商品同样金额,要求输出你最多可以获得的金额
解题思路
对两个数组从小到大排序,首先正向遍历,若二者均为负数,则累加其乘积,否则遍历结束;再反向遍历,若二者均为整数,则累加其乘积,否则结束遍历,详见代码
代码
#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long LL;
LL arr1[100005] = { 0 }, arr2[100005] = { 0 };//分别代表优惠券和商品价格
int main()
{
LL N1, N2, i, j;
int ret = scanf("%lld", &N1);
for (i = 0; i < N1; ++i) {
ret = scanf("%lld", &arr1[i]);
}
ret = scanf("%lld", &N2);
for (i = 0; i < N2; ++i) {
ret = scanf("%lld", &arr2[i]);
}
sort(arr1, arr1 + N1);
sort(arr2, arr2 + N2);
LL sum = 0;
for (i = 0; i < N1 && i < N2; ++i) {//处理负数
if (arr1[i] < 0 && arr2[i] < 0) {
sum += arr1[i] * arr2[i];
}
else break;
}
i = N1 - 1;
j = N2 - 1;
while (i >= 0 && j >= 0 && arr1[i] > 0 && arr2[j] > 0){//处理正数
sum += arr1[i] * arr2[j];
--i;
--j;
}
printf("%lld", sum);
return 0;
}